Project

General

Profile

Bug #16790

Revert to installing tor from torproject's stretch suite

Added by intrigeri about 1 month ago. Updated about 1 month ago.

Status:
Confirmed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Wait
Blueprint:
Starter:
Affected tool:

Description

If #16687 is merged with 585ca1efd1d6e4c1398d6d4b81016716ac11ad7d essentially as-is, we should revert most of that commit (modulo solving conflict correctly wrt. the APT snapshot bump) once the torproject's stretch suite has tor 0.4.x.


Related issues

Blocked by Tails - Feature #16687: Upgrade to tor 0.4.x Resolved
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed 03/22/2019

Associated revisions

Revision 06575833 (diff)
Added by anonym about 1 month ago

Install tor 0.4.x from Debian experimental.

In tpo's repo, tor 0.4.x has not moved to the buster suite yet (like
refs: #16790 for the stable suite) and our APT infra is not tracking
tor-experimental-0.4.0.x-buster so we cannot install from there.

This commit should be reverted once tor 0.4.x hits tpo's buster suite.

History

#1 Updated by intrigeri about 1 month ago

#2 Updated by intrigeri about 1 month ago

#3 Updated by anonym about 1 month ago

  • Status changed from Confirmed to In Progress

#4 Updated by anonym about 1 month ago

  • Status changed from In Progress to Confirmed
When doing this, also check if 0.4.x is in tpo's buster APT suite:
  • If yes: revert 06575833525720e029cdf4addabc482591129635 on feature/buster and we should be good (but please verify that tor 0.4.x is installed in a new feature/buster build!)
  • If no: open a new ticket (or repurpose this one) for doing the above "*yes*" step once 0.4.x is in tpo's buster APT suite

#5 Updated by intrigeri about 1 month ago

(@anonym, be aware that "refs: #nnnnn" sets a ticket as "In Progress"; it's a synonym of "Will-fix" actually.)

Also available in: Atom PDF