Project

General

Profile

Bug #16767

Schleuder mailing lists non functional: MXs of Autistici/Inventati are misconfigured

Added by u 6 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

Updates about the ongoing A/I infra migration:

Hi!

some mailing lists seem to "sleep". I've sent email to -summit and -accounting, none of which arrived. May you please check what's going on here? Thanks!


Related issues

Related to Tails - Bug #12113: Make sure tails.boum.org is available over IPv6 Confirmed 01/05/2017
Related to Tails - Bug #16121: Migrate our Schleuder lists outside of boum.org Resolved 12/11/2018

History

#1 Updated by u 6 months ago

Mailserver log says:

connect to mx2.investici.org[94.23.50.208]:25: Connection refused
connect to mx10.investici.org[198.167.222.108]:25: Connection refused
connect to mx2.investici.org[94.23.50.208]:25: Connection refused
connect to mx9.investici.org[212.103.72.250]:25: Connection refused

Connections over IPv6 seem to be impossible.

telnetting those IPs on port 25 from elsewhere is also impossible, so I guess the issue is not on my mailserver.

#2 Updated by u 6 months ago

  • Subject changed from Mailing lists non functional to Mailing lists non functional : MXs of investici unreachable

#3 Updated by goupille 6 months ago

when sending an email to tails-bugs@ I get an 'Undelivered Mail Returned to Sender' with this error :

Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error
    for name=mail.tails.boum.org type=AAAA: Host not found

I've got nothing explicit about not being able to connect to the MX...

#4 Updated by u 6 months ago

  • Assignee set to groente
  • Priority changed from Normal to Urgent

I also receive these messages:

<>: Host or domain name not found. Name service error
for name=mail.tails.boum.org type=AAAA: Host not found

Reporting-MTA: dns; mx1.investici.org
X-Postfix-Queue-ID: 7269C1207FA

AAAA = IPv6, right? I seem to remember that there is no IPv6 on t.b.o

This is still broken, I cannot send emails to our lists that are hosted on investici.org. Please fix this because noone can write to us currently on tails@, tails-accounting@ and -summit, and possibly other lists.

Tentatively assigning this to one of our sysadmins.

#5 Updated by sajolida 6 months ago

  • Subject changed from Mailing lists non functional : MXs of investici unreachable to Mailing lists non functional : MXs of autistici unreachable
  • Assignee deleted (groente)
  • Priority changed from Urgent to Normal

Mailing list archives return 404: https://lists.autistici.org/list/tails-project.html

It could be a different problem and I'll create a dedicated ticket if it turns out not to be.

#6 Updated by sajolida 6 months ago

If I understanding correctly:

  • Our public mailing lists are hosted by autistici
  • Our schleuder mailing lists are hosted either by puscii either by ourselves

I can write myself fine to for example.

#7 Updated by u 6 months ago

I now sent a private email to all of the sysadmins because nobody reacted to this since 24 hours.

#8 Updated by u 6 months ago

sajolida wrote:

If I understanding correctly:

  • Our public mailing lists are hosted by autistici
  • Our schleuder mailing lists are hosted either by puscii either by ourselves

I can write myself fine to for example.

I think this assumption is incorrect.
Currently affected:

-accounting@
-bugs@
-summit@
-sysadmins@

#9 Updated by u 6 months ago

sajolida wrote:

If I understanding correctly:

  • Our public mailing lists are hosted by autistici
  • Our schleuder mailing lists are hosted either by puscii either by ourselves

I can write myself fine to for example.

On top of that, their SSL cert is insecure.

#10 Updated by u 6 months ago

  • Assignee set to groente
  • Priority changed from Normal to Urgent

sajolida wrote:

Mailing list archives return 404: https://lists.autistici.org/list/tails-project.html

It could be a different problem and I'll create a dedicated ticket if it turns out not to be.

On top of that, their SSL cert is insecure.

#11 Updated by u 6 months ago

  • Assignee deleted (groente)

@groente @bertagaz @intrigeri I don't know who if you will handle this?

#12 Updated by u 6 months ago

Also sent email to now.

#13 Updated by u 6 months ago

  • Subject changed from Mailing lists non functional : MXs of autistici unreachable to Mailing lists non functional : MXs of autistici bounces back for mail.tails.boum.org

#14 Updated by u 6 months ago

  • Related to Bug #12113: Make sure tails.boum.org is available over IPv6 added

#15 Updated by u 6 months ago

  • Related to Bug #16121: Migrate our Schleuder lists outside of boum.org added

#16 Updated by u 6 months ago

  • Assignee set to groente

@groente seems to be on sysadmin duty, so reassigning back to him.

#18 Updated by intrigeri 6 months ago

  • Subject changed from Mailing lists non functional : MXs of autistici bounces back for mail.tails.boum.org to Schleuder mailing lists non functional : MXs of autistici bounces back for mail.tails.boum.org
  • Assignee changed from groente to intrigeri

(It seems that Mailman lists work just fine, apart of the archives part.)

I'll sum up what I understand of the problem to my contact at A/I.

We might have to wait a bit while their infrastructure is ongoing a full technological migration: they might have issues to fix that affect all their users, not just Tails.

#19 Updated by intrigeri 6 months ago

  • Subject changed from Schleuder mailing lists non functional : MXs of autistici bounces back for mail.tails.boum.org to Schleuder mailing lists non functional: MXs of Autistici/Inventati are misconfigured

(This report is not only about lists we host at mail.tails.b.o.)

#20 Updated by intrigeri 6 months ago

  • Status changed from Confirmed to In Progress

sajolida wrote:

If I understanding correctly:

  • Our public mailing lists are hosted by autistici
  • Our schleuder mailing lists are hosted either by puscii either by ourselves

FTR, since this was challenged later here: this is entirely correct (as per the final decision, that was made on tails@).

#21 Updated by intrigeri 6 months ago

  • Description updated (diff)

#22 Updated by u 6 months ago

intrigeri wrote:

sajolida wrote:

If I understanding correctly:

  • Our public mailing lists are hosted by autistici
  • Our schleuder mailing lists are hosted either by puscii either by ourselves

FTR, since this was challenged later here: this is entirely correct (as per the final decision, that was made on tails@).

Right. But this is not the issue causing the bug.

#23 Updated by intrigeri 6 months ago

  • Assignee changed from intrigeri to groente

@groente has more direct means of communication with A/I folks at the moment so it probably makes more sense that he handles this :)

#24 Updated by groente 6 months ago

  • Status changed from In Progress to Resolved

everything seems to work again \o/

#25 Updated by intrigeri 6 months ago

  • Status changed from Resolved to In Progress
  • Assignee changed from groente to intrigeri

everything seems to work again \o/

Woohoo!

… except that none of our systems can deliver email to @boum.org, because the TLS policy we have in place does not match the new A/I setup. I'll handle it.

#26 Updated by intrigeri 6 months ago

  • Assignee changed from intrigeri to groente
  • QA Check set to Ready for QA

It seems the best we can do at the moment is https://git.tails.boum.org/puppet-tails/commit/?id=5b8c54b46820f25fda812d0f1e73f7807cdca420. Deployed on a few systems and confirmed it allowed email flow to resume (see e.g. the Icinga2 notifications that just arrived on our team's list). I've also confirmed that it allowed whisperback.lizard to deliver a bunch of queued WhisperBack reports to our Help Desk.

#27 Updated by intrigeri 6 months ago

  • Status changed from In Progress to Needs Validation

#28 Updated by groente 5 months ago

  • Status changed from Needs Validation to Resolved

Also available in: Atom PDF