Project

General

Profile

Bug #16762

Document why NoScript last update is january 2000

Added by mercedes508 23 days ago. Updated 9 days ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:
Browser

Description

Users start to get worried about the fact that NoScript last update is apparently January 2000 according to Tor Browser add-ons tab. Even though its version is obviously newer than that.

I've been told it's been hardcoded for build reproducibility purpose.

We should document that somewhere, maybe?

2000-01-01.png View (38.5 KB) sajolida, 06/02/2019 06:37 PM

History

#1 Updated by sajolida 15 days ago

  • File 2000-01-01.png View added
  • Status changed from Confirmed to New
  • Assignee deleted (sajolida)

When you write "users", do you mean that this was reported by several people?

See screenshot in attachment.

It's not great, especially since uBlock Origin displays a correct date. On the other hand, the version number is correct.

@intrigeri: If it's trival, could we use the date of the last commit in the build instead of 2000-01-01?

If it's not trivial to fix in the code, I think we shouldn't bother even documenting it. We have tons of more important stuff to do before that one.

#2 Updated by sajolida 15 days ago

  • Assignee set to sajolida

#3 Updated by mercedes508 14 days ago

sajolida wrote:

When you write "users", do you mean that this was reported by several people?

2 users actually.

#4 Updated by intrigeri 9 days ago

  • Affected tool set to Browser

#5 Updated by intrigeri 9 days ago

  • Status changed from New to Rejected

intrigeri: If it's trival, could we use the date of the last commit in the build instead of 2000-01-01?

I don't think it's worth adding and maintaining Tails-specific kludges about that: our special Tor Browser installation Frankenstein method is hard enough to keep alive.
Tor Browser 8.5.1 is affected too (except it'll allow updating NoScript so after some time, if there's a NoScript update, the date will get fixed, while we disallow such updates for some reason in Tails) ⇒ I've reported this upstream: https://trac.torproject.org/projects/tor/ticket/30810.

If it's not trivial to fix in the code, I think we shouldn't bother even documenting it. We have tons of more important stuff to do before that one.

I'd like to add that IMO, this happens right now because the NoScript icon was recently hidden, combined with the recent armagadd-on bug that disabled NoScript: I think these two factors explain why concerned users go double-check in about:addons whether NoScript is really enabled, and then notice this weird date. I'm pretty sure that after a few weeks or months, users will regain their trust in "NoScript is up-to-date and enabled in Tails" and will stop bothering, which will make this entire ticket moot.

Rejecting, then. Hopefully this will get fixed upstream!

Also available in: Atom PDF