Project

General

Profile

Bug #16759

Memory erasure is slower on Buster than on 3.x

Added by hefee about 1 month ago. Updated 8 days ago.

Status:
Duplicate
Priority:
Elevated
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

On Jenkins features/erase_memory.feature:62 # Scenario: Erasure of the aufs read-write branch on shutdown fails quite often. e.g. https://jenkins.tails.boum.org/job/test_Tails_ISO_feature-buster/181/cucumberTestReport/system-memory-erasure-on-shutdown/erasure-of-the-aufs-read-write-branch-on-shutdown/

As temporarily solution I bump the sleep time from 20 -> 40 secs, so we have a more stable test result.

As the erase_memory is a important feature of tails, we should have a look, why this got slower from 3.X -> 4.X.


Related issues

Duplicates Tails - Bug #16743: Restore Tails boot splash on Buster Resolved

Associated revisions

Revision 5f6c4826 (diff)
Added by Sandro Knauß about 1 month ago

Extend sleep time, for searching known patterns in memory. (refs: #16759)

The removal of known patterns needs more time in some cases, in order
to get the tests passes more reliably.

Revision 4f597d56
Added by anonym 9 days ago

Merge remote-tracking branch 'origin/hefee/erase_memory' into feature/buster

Fix-committed: #16759

Revision c47139be (diff)
Added by intrigeri 8 days ago

Revert "Extend sleep time, for searching known patterns in memory" (refs: #16759)

All indicators suggest that the bug workaround'ed by the commit
I'm reverting was a side-effect of #16743, which is now fixed.

This reverts commit 5f6c4826dcc92f7a3556b48e67629add2a7a9e24.

History

#1 Updated by Anonymous about 1 month ago

  • Status changed from Confirmed to In Progress

#2 Updated by hefee about 1 month ago

  • Status changed from In Progress to Confirmed

#3 Updated by anonym 9 days ago

  • Category set to Test suite
  • Status changed from Confirmed to Needs Validation
  • Assignee set to anonym
  • Type of work changed from Research to Code

#4 Updated by anonym 9 days ago

  • Feature Branch set to hefee/erase_memory, https://salsa.debian.org/tails-team/tails/merge_requests/27/commits

#5 Updated by anonym 9 days ago

  • Status changed from Needs Validation to Fix committed
  • % Done changed from 0 to 100

#6 Updated by anonym 9 days ago

  • Status changed from Fix committed to Resolved
  • Assignee deleted (anonym)
  • % Done changed from 100 to 0

#7 Updated by anonym 9 days ago

  • % Done changed from 0 to 100

#8 Updated by intrigeri 8 days ago

  • Category deleted (Test suite)
  • Status changed from Resolved to Confirmed
  • Feature Branch deleted (hefee/erase_memory, https://salsa.debian.org/tails-team/tails/merge_requests/27/commits)
  • Type of work changed from Code to Research

@anonym, this ticket was meant to track the actual problem in Tails (which I think we still should do), not the workaround in the test suite.

#9 Updated by intrigeri 8 days ago

  • Priority changed from Normal to Elevated

Let's at least give it a try before we publish a first public beta.

#10 Updated by intrigeri 8 days ago

  • Subject changed from feature/buster: erase_memory is slower than on 3.x to Memory erasure is slower on Buster than on 3.x

#11 Updated by intrigeri 8 days ago

Given:

  • The entire "Feature: System memory erasure on shutdown" has consistently passed in the last 24 runs of feature/buster on Jenkins, since the fix for #16743 was merged; note that all these tests were run without the timeout bump from !27.
  • Looking at the video that hefee linked to, I see the Debian Buster default splash screen with a very sluggish animation, i.e. this bug was reported before #16743 was fixed.

It seems that this bug was a side-effect of #16743. I guess that our own splash screen is much cheaper on the CPU and does not delay memory erasure as much as the splash theme used while reporting this bug.

So I think we should:

  • Revert !27, which seems unnecessary and could hide a future regression in this area.
  • Close this ticket as a duplicate of #16743.

I'm happy to do both myself but I'd first like to give @hefee and @anonym a chance to point out whatever my reasoning may have missed :)

#12 Updated by intrigeri 8 days ago

  • Status changed from Confirmed to In Progress

#13 Updated by hefee 8 days ago

  • Assignee set to hefee

#14 Updated by hefee 8 days ago

  • Assignee changed from hefee to intrigeri

intrigeri wrote:

I think we should:

  • Revert !27, which seems unnecessary and could hide a future regression in this area.
  • Close this ticket as a duplicate of #16743.

I'm happy to do both myself.

Please do, as Jenkins approved this and also like to see that we can lower the sleep time again!

#15 Updated by intrigeri 8 days ago

  • Duplicates Bug #16743: Restore Tails boot splash on Buster added

#16 Updated by intrigeri 8 days ago

  • Status changed from In Progress to Duplicate

Also available in: Atom PDF