Project

General

Profile

Bug #16757

Remove tails-greeter's dependency on libcaribou-gtk3-module

Added by intrigeri 3 months ago. Updated 3 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
feature/16912-move-greeter-to-main-git-repo+force-all-tests
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Greeter

Description

Let's do this once 4.0 is out (rationale: #16628).


Related issues

Related to Tails - Bug #16628: Remove caribou Resolved
Related to Tails - Feature #11430: "Screen Keyboard" doesn't work in new Greeter Resolved 05/17/2016
Related to Tails - Feature #16912: Move greeter source to main git repo Resolved
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed 03/22/2019

Associated revisions

Revision e61076ee (diff)
Added by intrigeri 15 days ago

Stop installing libcaribou-gtk3-module (refs: #16757)

We wanted to do this earlier (#16628) but it would have been a pain since we
did not build a Buster-specific version of tails-greeter yet. Now that
we list these dependencies in tails.git, it's easy to drop it.

Revision 98b01537
Added by intrigeri 3 days ago

Merge branch 'feature/16912-move-greeter-to-main-git-repo+force-all-tests' into devel (Fix-committed: #16912, #12551, #16757)

History

#1 Updated by intrigeri 3 months ago

#2 Updated by intrigeri 3 months ago

  • Related to Feature #11430: "Screen Keyboard" doesn't work in new Greeter added

#3 Updated by intrigeri 3 months ago

#4 Updated by intrigeri 3 months ago

#5 Updated by intrigeri 15 days ago

  • Assignee set to intrigeri
  • Target version set to Tails_4.0
  • Feature Branch set to feature/16912-move-greeter-to-main-git-repo+force-all-tests

#6 Updated by intrigeri 15 days ago

  • Related to Feature #16912: Move greeter source to main git repo added

#7 Updated by intrigeri 15 days ago

#8 Updated by intrigeri 15 days ago

  • Status changed from Confirmed to In Progress

#9 Updated by intrigeri 14 days ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from intrigeri to anonym

(This goes with #16912.)

#10 Updated by intrigeri 3 days ago

  • Status changed from Needs Validation to Fix committed
  • % Done changed from 0 to 100

#11 Updated by intrigeri 3 days ago

  • Status changed from Fix committed to Resolved
  • % Done changed from 100 to 0

Also available in: Atom PDF