Project

General

Profile

Bug #16736

Test suite regression in 3.14: Scenario: I am notified when Additional Software fails to install a package

Added by CyrilBrulebois 27 days ago. Updated 15 days ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Spotted in Jenkins but also reproduced locally with features/additional_software_packages.feature:

    Then I see the "The installation of your additional software failed" notification after at most 300 seconds # features/step_definitions/common_steps.rb:357
      try_for() timeout expired (Timeout::Error)
      ./features/support/helpers/misc_helpers.rb:90:in `rescue in try_for'
      ./features/support/helpers/misc_helpers.rb:36:in `try_for'
      ./features/step_definitions/common_steps.rb:363:in `/^I see the "(.+)" notification(?: after at most (\d+) seconds)?$/'
      features/additional_software_packages.feature:123:in `Then I see the "The installation of your additional software failed" notification after at most 300 seconds'
    And I can open the Additional Software log file from the notification                                       # features/step_definitions/additional_software_packages.rb:137
    And the package "cowsay" is not installed                                                                   # features/step_definitions/common_steps.rb:591
00:39:56.740644289: calling as root: echo 'hello?'
00:39:56.961367348: call returned: [0, "hello?\n", ""]
00:39:56.961670528: calling as root: journalctl -a --no-pager > /tmp/systemd.journal
00:39:57.105344995: call returned: [0, "", ""]
00:39:57.105508352: opening file /tmp/systemd.journal in 'read' mode
00:40:01.766670767: read complete
      Scenario failed at time 00:39:56

[…]      

Failing Scenarios:
cucumber features/additional_software_packages.feature:114 # Scenario: I am notified when Additional Software fails to install a package

6 scenarios (1 failed, 5 passed)
79 steps (1 failed, 2 skipped, 76 passed)

Looking at the video, it seems that the notification does appear, before the whole screen flashes to black and gets back without the notification.

See the three attached screenshots for reference.

as1.png View - original notification (48.4 KB) CyrilBrulebois, 05/21/2019 02:49 PM

as2.png View - all black (6.87 KB) CyrilBrulebois, 05/21/2019 02:50 PM

as3.png View - notification gone (58.5 KB) CyrilBrulebois, 05/21/2019 02:50 PM


Related issues

Duplicates Tails - Bug #11188: GNOME Shell sometimes crashes and restarts Confirmed 03/03/2016
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed 03/22/2019

History

#1 Updated by intrigeri 25 days ago

#2 Updated by intrigeri 15 days ago

  • Status changed from Confirmed to Duplicate

I can't find this failure on https://jenkins.tails.boum.org/view/RM/job/test_Tails_ISO_stable/, neither around the time this bug was filed, nor in the last ~2 weeks. So this seems to be a test suite fragility issue rather than a regression.

Looking at the video, it seems that the notification does appear, before the whole screen flashes to black and gets back without the notification.

I'm pretty sure that's #11188 i.e. a bug in topIcons (that's supposedly been at least partly fixed in Buster IIRC), so I don't think there's anything we can do here, that's not covered by #8309 already, so I'm closing this ticket as a duplicate. Please reopen, attaching the debug log and the Journal, if I guessed wrong :)

#3 Updated by intrigeri 15 days ago

  • Duplicates Bug #11188: GNOME Shell sometimes crashes and restarts added

Also available in: Atom PDF