Project

General

Profile

Bug #16728

Upgrade firmware-amd-graphics (and the rest of firmware-nonfree)

Added by intrigeri 5 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Hardware support
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
bugfix/16728-upgrade-firmware-amd-graphics
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description


Related issues

Related to Tails - Bug #16708: Upgrade Linux to 4.19.37 Resolved
Related to Tails - Bug #16973: Drop CSS hack for uBlock Origin sidebar Rejected
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed
Blocks Tails - Bug #16970: Upgrade to Linux 4.19 with the Spectre v1 swapgs mitigations in Tails 3.16 Resolved

Associated revisions

Revision 6bac4187 (diff)
Added by segfault 2 months ago

Revert "Install firmware-amd-graphics from stretch-backports" (refs: #16728)

This reverts the following commits:

4fbcc2a1013f8eff16de5a933932634aed4da042
1ffd91d13e3b7b0bb60bc4184cc0ef7fbe943e90
575ee712cfab9c4863e6c549788b604320fa372b

Bug https://bugs.debian.org/928631 was fixed in
firmware-nonfree/20190717-1, so we can now revert to installing
firmware-amd-graphics from sid.

Revision d17bf91b (diff)
Added by segfault 2 months ago

Install hunspell-id, hunspell-tr from Buster (refs: #16728)

Revision 492d951f (diff)
Added by segfault 2 months ago

Install fonts-noto-* from Buster (refs: #16728)

Revision 02bae209 (diff)
Added by segfault 2 months ago

Bump APT snapshot of the Debian archive to 2019080801 (refs: #16728)

It brings firmware-nonfree 20190717-1 which fixes
https://bugs.debian.org/928631.

Revision 6b0fbd32
Added by intrigeri 2 months ago

Merge remote-tracking branch 'origin/bugfix/16728-upgrade-firmware-amd-graphics' into stable (Fix-committed: #16728, #16970)

History

#1 Updated by intrigeri 5 months ago

#2 Updated by intrigeri 5 months ago

  • Related to Bug #16708: Upgrade Linux to 4.19.37 added

#3 Updated by intrigeri 4 months ago

  • Target version changed from Tails_3.15 to Tails_3.16

The bug is not fixed in Debian yet.

#4 Updated by intrigeri 2 months ago

  • Subject changed from Upgrade firmware-amd-graphics to Upgrade firmware-amd-graphics (and the rest of firmware-nonfree)
  • Type of work changed from Wait to Code

Fixed in firmware-nonfree/20190717-1 which brings a bunch of other improvements.

If the .packages diff between stable and devel feels safe, we could bump the "debian" APT snapshot. Else, we have to upload this new version to our custom APT repo. In any case, see the ticket description for additional action that's needed.

@segfault, would you take this one? If not, I'll do it.

#5 Updated by segfault 2 months ago

  • Assignee set to segfault

#6 Updated by segfault 2 months ago

  • Status changed from Confirmed to In Progress

#7 Updated by segfault 2 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (segfault)
  • Feature Branch set to bugfix/16728-upgrade-firmware-amd-graphics

#8 Updated by segfault 2 months ago

  • Status changed from Needs Validation to In Progress
  • Assignee set to segfault

Forgot to bump the APT snapshot

#9 Updated by segfault 2 months ago

intrigeri wrote:

If the .packages diff between stable and devel feels safe, we could bump the "debian" APT snapshot.

Here is the diff between the latest builds of stable and devel:

diff -Naur ./torbrowser-downloads/tails-amd64-devel-3.17-20190806T0658Z-dbbf93bfaa.packages ./torbrowser-downloads/tails-amd64-stable-3.16-20190806T0717Z-dc88e9269a.packages
--- ./torbrowser-downloads/tails-amd64-devel-3.17-20190806T0658Z-dbbf93bfaa.packages    2019-08-07 00:42:03.259179800 +0200
+++ ./torbrowser-downloads/tails-amd64-stable-3.16-20190806T0717Z-dc88e9269a.packages    2019-08-07 00:42:11.143201839 +0200
@@ -128,18 +128,18 @@
 findutils    4.6.0+git+20161106-2
 firefox    60.8.0+fake1
 firmware-amd-graphics    20190114-1~bpo9+2
-firmware-atheros    20190717-1
+firmware-atheros    20190502-1
 firmware-b43-installer    1:019-4
 firmware-b43legacy-installer    1:019-4
-firmware-brcm80211    20190717-1
-firmware-intel-sound    20190717-1
-firmware-ipw2x00    20190717-1
-firmware-iwlwifi    20190717-1
-firmware-libertas    20190717-1
+firmware-brcm80211    20190502-1
+firmware-intel-sound    20190502-1
+firmware-ipw2x00    20190502-1
+firmware-iwlwifi    20190502-1
+firmware-libertas    20190502-1
 firmware-linux-free    3.4
-firmware-misc-nonfree    20190717-1
-firmware-realtek    20190717-1
-firmware-ti-connectivity    20190717-1
+firmware-misc-nonfree    20190502-1
+firmware-realtek    20190502-1
+firmware-ti-connectivity    20190502-1
 firmware-zd1211    1:1.5-6
 fontconfig    2.11.0-6.7.0tails4
 fontconfig-config    2.11.0-6.7.0tails4
@@ -149,7 +149,7 @@
 fonts-dejavu-extra    2.37-1
 fonts-liberation    1:1.07.4-2
 fonts-linuxlibertine    5.3.0-2
-fonts-noto-cjk    1:20190410+repack1-1
+fonts-noto-cjk    1:20170601+repack1-3
 fonts-noto-core    20181227-1
 fonts-noto-mono    20181227-1
 fonts-noto-ui-core    20181227-1
@@ -301,11 +301,11 @@
 hunspell-fr    1:5.7-1
 hunspell-fr-classical    1:5.7-1
 hunspell-hi    1:5.2.5-1
-hunspell-id    1:6.3.0~rc1-1
+hunspell-id    1:6.2.0-1
 hunspell-it    1:5.2.5-1
 hunspell-pt-br    1:5.2.5-1
 hunspell-ru    1:5.2.5-1
-hunspell-tr    1:6.3.0~rc1-1
+hunspell-tr    1:6.2.0-1
 ibus    1.5.14-3+deb9u1
 ibus-anthy    1.5.9-2
 ibus-chewing    1.5.1-1+b1
@@ -1350,7 +1350,7 @@
 libzvbi-common    0.2.35-13
 libzvbi0:amd64    0.2.35-13
 linux-base    4.5
-linux-image-4.19.0-5-amd64    4.19.37-6
+linux-image-4.19.0-5-amd64    4.19.37-4
 live-boot    1:20170112
 live-boot-initramfs-tools    1:20170112
 live-config    5.20170112+deb9u1
@@ -1624,7 +1624,7 @@
 virtualbox-guest-dkms-dummy    5.2.24-dfsg-4~bpo9+1+tails.fake1
 virtualbox-guest-utils    5.2.24-dfsg-4~bpo9+1
 virtualbox-guest-x11    5.2.24-dfsg-4~bpo9+1
-webext-ublock-origin    1.19.0+dfsg-2
+webext-ublock-origin    1.18.4+dfsg-2
 wget    1.18-5+deb9u3
 whiptail    0.52.19-1+b1
 whisperback    1.7.23

@intrigeri, what do you say? Should I bump the snapshot?

#10 Updated by intrigeri 2 months ago

intrigeri, what do you say? Should I bump the snapshot?

LGTM except:

  • We should install fonts-noto-* from Buster, now that sid has diverged: on feature/buster we do that already and ed7a35df256a8938af9fad82cb02eb43223e6e1a suggests that's good enough. Otherwise we'll have to choose between 1. downgrading these packages in 4.0; 2. keep tracking sid for the entire lifetime of 4.x.
  • Same for hunspell-id and hunspell-tr.

#11 Updated by segfault 2 months ago

Bumping the serial causes the build to fail because our webext-ublock-origin patch doesn't apply anymore. I will try to fix that.

#12 Updated by intrigeri 2 months ago

Bumping the serial causes the build to fail because our webext-ublock-origin patch doesn't apply anymore. I will try to fix that.

In general, such issues are already fixed on devel. It's the case here: #16858. So you can cherry-pick the fix. I wouldn't be surprised if there were a couple more such instances.

#13 Updated by intrigeri 2 months ago

  • Blocks Bug #16970: Upgrade to Linux 4.19 with the Spectre v1 swapgs mitigations in Tails 3.16 added

#14 Updated by segfault 2 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (segfault)

#15 Updated by segfault 2 months ago

  • Related to Bug #16973: Drop CSS hack for uBlock Origin sidebar added

#16 Updated by intrigeri 2 months ago

  • Assignee set to intrigeri

Code review passes. I've bumped the expiration date of the APT snapshot used on this branch.

#17 Updated by intrigeri 2 months ago

  • Status changed from Needs Validation to Fix committed
  • % Done changed from 0 to 100

#18 Updated by CyrilBrulebois about 1 month ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF