Project

General

Profile

Feature #16725

Create custom electrum package

Added by segfault about 1 month ago. Updated about 1 month ago.

Status:
Confirmed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
Affected tool:

History

#1 Updated by segfault about 1 month ago

  • Related to Bug #16708: Upgrade Linux to 4.19.37 added

#2 Updated by segfault about 1 month ago

I can't build the package because Electrum now depends on aiohttp_socks, which is not packaged for Debian.

#3 Updated by u about 1 month ago

There is work done on the Debian side too: https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1678417.html Apparently there are even two missing modules: aiohttp_socks and aiorpcx. We would need to open to RFP bugs for Debian for these two packages. Or package these ourselves. Not sure if we want to do that.

#4 Updated by intrigeri about 1 month ago

  • Target version changed from Tails_3.14 to Tails_3.15
  • Type of work changed from Code to Discuss

As said on #16708#note-22, working on this seems quite premature to me given the state of the discussions we're having on tails-dev@ about the future of Electrum in Debian and Tails. Let's say it was worth a try but given it's non-trivial, very late in the 3.14 cycle, and we have more urgent matters to tackle in time for 3.14, I say let's give up for 3.14 and instead lead the ongoing discussions towards a conclusion during the 3.15 cycle.

#5 Updated by intrigeri about 1 month ago

  • Related to deleted (Bug #16708: Upgrade Linux to 4.19.37)

Also available in: Atom PDF