Project

General

Profile

Bug #16715

rewrite the workaround about Soft Lockup

Added by goupille 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

the "soft lockup - CPU#X stuck for 22s" is affecting several computers (some of them are listed in the comment of #15774, but there are more, like the MSI Ghost GS60). usually the workarounds proposed for the xps 9560 are working on those computers, but the users are having trouble finding it by themselves due to the lack of details in the known issue entry (https://tails.boum.org/support/known_issues/index.en.html#index14h3).

it would be really great if, at least, the error message was specified, and if there was an anchor to that specific entry.


Related issues

Blocks Tails - Feature #15941: Core work 2018Q4 → 2019Q2: Technical writing Resolved 09/11/2018

Associated revisions

Revision 81535968
Added by sajolida 6 months ago

Merge branch 'doc/16715-soft-lockup' (Closes: #16715)

History

#1 Updated by sajolida 6 months ago

  • Blocks Feature #15941: Core work 2018Q4 → 2019Q2: Technical writing added

#2 Updated by sajolida 6 months ago

  • Assignee changed from sajolida to goupille
  • Target version set to Tails_3.14
  • QA Check set to Ready for QA

Please have a look at a16336e66c.

Can you confirm that:

  • This issue is better placed in known_issues/graphics than known_issues.
  • The "soft lockup" error is somehow displayed before the screen goes black.

#3 Updated by goupille 6 months ago

sajolida wrote:

Can you confirm that:

  • This issue is better placed in known_issues/graphics than known_issues.

as far as I know, the users facing the issues listed in known_issues/graphics are shown the custom error message linking to tails.boum.org/gdm. the users facing the soft lockup thing are not shown this issue, so I think it would be better to put it in known_issues

  • The "soft lockup" error is somehow displayed before the screen goes black.

as far as I understand, the users are shown this error and the boot process is stopped, (i can't remember if the user needs to do something like removing quiet to see it or if the message is shown anyway)

#4 Updated by goupille 6 months ago

regarding to a16336e66c:

- IIRC, it was the first workaround we found that broke the backlight for some laptops, given the other workarounds (including the one we document on the known issues page) it seems to be more of an ACPI issue than a graphic issue.

- sorry to insist, but I'd love to have an id= to link it to users, as I think that even if it is in the known issues, we will still need to point it to some people

#5 Updated by goupille 6 months ago

  • Assignee changed from goupille to sajolida

#6 Updated by sajolida 6 months ago

the issues listed in known_issues/graphics are shown the custom error message linking to tails.boum.org/gdm

Only the 1st part of the page ("Error starting GDM") is about /gdm. The
rest of the page ("Other issues") is about other graphics issues.

as far as I understand, the users are shown this error and the boot process is stopped, (i can't remember if the user needs to do something like removing quiet to see it or if the message is shown anyway)

Ok, so my slightly generic phrasing should work fine :)

I'm merging then. Thanks for the quick turnaround!

#7 Updated by sajolida 6 months ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

#8 Updated by sajolida 6 months ago

- IIRC, it was the first workaround we found that broke the backlight for some laptops, given the other workarounds (including the one we document on the known issues page) it seems to be more of an ACPI issue than a graphic issue.

Ok, then I moved it back to /support/known_issues.

- sorry to insist, but I'd love to have an id= to link it to users, as I think that even if it is in the known issues, we will still need to point it to some people

Here you go:

https://tails.boum.org/support/known_issues/#lockup

#9 Updated by sajolida 6 months ago

  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

Also available in: Atom PDF