Project

General

Profile

Feature #16687

Upgrade to tor 0.4.x

Added by intrigeri 7 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
feature/16687-tor-0.4.0.x+force-all-tests
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed
Blocks Tails - Bug #16471: Drop time synchronization hacks that tor 0.3.5 and 0.4.x made obsolete In Progress 02/17/2019
Blocks Tails - Bug #16790: Revert to installing tor from torproject's buster suite Resolved

Associated revisions

Revision b406d174 (diff)
Added by intrigeri 5 months ago

Install tor 0.4.0.x from tor-experimental-0.4.0.x-stretch (refs: #16687)

Revision 585ca1ef (diff)
Added by intrigeri 5 months ago

Install tor 0.4.0.x from tor-experimental-0.4.0.x-stretch (refs: #16687)

Revision b3078723
Added by anonym 5 months ago

Merge remote-tracking branch 'origin/feature/16687-tor-0.4.0.x+force-all-tests' into stable

Fix-committed: #16687

Revision 5f5561c0
Added by anonym 5 months ago

Merge remote-tracking branch 'origin/devel' into feature/buster

This merge backs out the upgrade to tor 0.4.x (refs: #16687) -- that
upgrade will be done in a future commit that we easily can revert when
tor 0.4.x is added to tpo's buster APT suite, similar to #16790.

History

#1 Updated by intrigeri 7 months ago

#2 Updated by hefee 6 months ago

  • Blocks Bug #16471: Drop time synchronization hacks that tor 0.3.5 and 0.4.x made obsolete added

#3 Updated by intrigeri 6 months ago

  • Subject changed from Upgrade to Tor 0.4.x to Upgrade to tor 0.4.x

#4 Updated by intrigeri 6 months ago

  • Type of work changed from Code to Wait

Let's wait for https://deb.torproject.org/torproject.org/dists/stretch/main/binary-amd64/Packages to have 0.4.x. I'm not sure what's the reason for the delay (we could ask weasel) since 0.4.x was declared stable already.

#5 Updated by intrigeri 5 months ago

  • Type of work changed from Wait to Code

intrigeri wrote:

Let's wait for https://deb.torproject.org/torproject.org/dists/stretch/main/binary-amd64/Packages to have 0.4.x. I'm not sure what's the reason for the delay (we could ask weasel) since 0.4.x was declared stable already.

I see 0.4.0.5 is packaged in https://deb.torproject.org/torproject.org/dists/tor-experimental-0.4.0.x-stretch/main/binary-amd64/Packages. I'm pretty sure I'm guessing right that it's there, and not in their stretch dist, only because tor 0.4.x will only be in Debian experimental until the Buster release. I don't think we should block on this to upgrade ourselves given 0.4.x is stable from upstream's PoV and this upgrade is needed for other ongoing work of ours (#16471).

So IMO we should:

  • create a branch forked off stable that switches to the tor-experimental-0.4.0.x-stretch dist; then work that depends on tor 0.4.x can be based on that new branch
  • file a ticket to revert this change once 0.4.x is in the stretch dist

#6 Updated by intrigeri 5 months ago

  • Assignee set to intrigeri

intrigeri wrote:

  • create a branch forked off stable that switches to the tor-experimental-0.4.0.x-stretch dist; then work that depends on tor 0.4.x can be based on that new branch

I'll do that so that I can push to Jenkins a branch based on stable that has hefee's changes from #16471 except the Chutney ones. At this point I'm not committing to do more on this very ticket though.

#7 Updated by intrigeri 5 months ago

  • Feature Branch set to feature/16687-tor-0.4.0.x+force-all-tests

#8 Updated by intrigeri 5 months ago

  • Status changed from Confirmed to In Progress

#9 Updated by intrigeri 5 months ago

  • Blocks Bug #16790: Revert to installing tor from torproject's buster suite added

#10 Updated by intrigeri 5 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (intrigeri)

Every test passed at least once in the 3 runs on Jenkins except:

  • the DCHP ones: recently introduced regression, I've already filed a ticket for @anonym about it
  • the Totem WebM HTTPS one: tested manually, works fine

@anonym, @hefee, can one of you please review? Thanks in advance!

#11 Updated by anonym 5 months ago

  • Assignee set to anonym

#12 Updated by anonym 5 months ago

  • Status changed from Needs Validation to Fix committed
  • % Done changed from 0 to 100

#13 Updated by anonym 5 months ago

  • Assignee deleted (anonym)
  • % Done changed from 100 to 0

LGTM!

#14 Updated by anonym 5 months ago

  • Status changed from Fix committed to In Progress

#15 Updated by intrigeri 5 months ago

  • Status changed from In Progress to Fix committed

@anonym, I assume this was a mistake.

#16 Updated by intrigeri 5 months ago

  • Status changed from Fix committed to Resolved
  • Target version changed from Tails_3.15 to Tails_3.14.1

This was shipped in 3.14.1.

Also available in: Atom PDF