Project

General

Profile

Bug #16670

Upgrade to Stretch 9.9

Added by intrigeri 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
bugfix/16670-upgrade-to-stretch-9.9+force-all-tests
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision 37802dee (diff)
Added by segfault 5 months ago

Enable and use the Debian stretch-proposed-updates APT repository, anticipating on the Stretch 9.9 point release (refs: #16670)

Revision 73acbabf (diff)
Added by segfault 5 months ago

Bump APT snapshot of the 'debian' archive to 2019031401 (refs: #16670)

Revision 6471cdf0 (diff)
Added by intrigeri 5 months ago

Bump the "debian" APT snapshot to a version that has Stretch 9.9 and stop using stretch-proposed-updates (refs: #16670).

This reverts commit 37802dee1f8aefa4535c624a8c583bf42a4fdb50.

Stretch 9.9 is out ⇒ we don't need p-u anymore :)

Revision 8649772c
Added by intrigeri 5 months ago

Merge branch 'bugfix/16670-upgrade-to-stretch-9.9+force-all-tests' into stable

Fix-committed: #16670

History

#1 Updated by intrigeri 5 months ago

  • Description updated (diff)
  • Target version set to Tails_3.14

Let's at least consider this for 3.14.

#2 Updated by intrigeri 5 months ago

#3 Updated by intrigeri 5 months ago

  • Description updated (diff)

#4 Updated by segfault 5 months ago

  • Status changed from Confirmed to In Progress

#5 Updated by segfault 5 months ago

The build fails because the electrum package is not available in the latest APT snapshot.

#6 Updated by intrigeri 5 months ago

The build fails because the electrum package is not available in the latest APT snapshot.

Yep, as said yesterday, we'll need to cherry-pick FTBFS fixes from devel until the branch builds.

#7 Updated by intrigeri 5 months ago

  • Assignee set to intrigeri

@segfault, I'll give it a try today and we'll see where this goes.

#8 Updated by intrigeri 5 months ago

  • Feature Branch set to bugfix/16670-upgrade-to-stretch-9.9+force-all-tests

#9 Updated by intrigeri 5 months ago

OK, it builds. The diff between the .packages from a stable build done today and a build from this branch looks OK, nothing scary, and some welcome fixes. So I think we should do that in 3.14. Waiting for CI results.

#10 Updated by intrigeri 5 months ago

Stretch 9.9 is out so we could now drop 37802dee1f8aefa4535c624a8c583bf42a4fdb50 from this branch.

#11 Updated by intrigeri 5 months ago

Across 3 local full test suite runs I've seen all scenarios pass except the OpenPGP applet ones (expected since we disabled topIcons for now).

#12 Updated by intrigeri 5 months ago

  • Assignee deleted (intrigeri)
  • QA Check set to Ready for QA

@hefee or @segfault, anyone up for a "review"?

#13 Updated by hefee 5 months ago

  • Assignee set to hefee

#14 Updated by hefee 5 months ago

  • Assignee changed from hefee to intrigeri
  • QA Check changed from Ready for QA to Info Needed

[x] checked the git diff
[x] checked from the package list on Jenkins that Electrum 3.2.3-1 is listed
[] Electrum Bitcoin client ǂ Using a persistent Electrum configuration failed since build 2.

Maybe this test failure is acceptable, as electrum is currently not in a good shape at all.

I didn't spin up this iso on a VM.

#15 Updated by intrigeri 5 months ago

  • Assignee changed from intrigeri to hefee
  • QA Check changed from Info Needed to Ready for QA

Thanks @hefee for the review!

[] Electrum Bitcoin client ǂ Using a persistent Electrum configuration failed since build 2.

Maybe this test failure is acceptable, as electrum is currently not in a good shape at all.

tl;dr: not a regression brought by this branch.

Electrum in Tails can rarely connect to the network (#16421) which makes this test case fail most of the time, be it on stable-based branches or on this one. To fix that, we'll need a version of Electrum that's not in Debian yet, hence the conversation we had at the sprint last month, that's been going on on tails-\@dev- since.

#16 Updated by hefee 5 months ago

  • Assignee changed from hefee to intrigeri
  • QA Check changed from Ready for QA to Pass

intrigeri wrote:

tl;dr: not a regression brought by this branch.

Electrum in Tails can rarely connect to the network (#16421) which makes this test case fail most of the time, be it on stable-based branches or on this one. To fix that, we'll need a version of Electrum that's not in Debian yet, hence the conversation we had at the sprint last month, that's been going on on tails-\@dev- since.

okay than - it is ready for merge.

#17 Updated by intrigeri 5 months ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 0 to 100

#18 Updated by intrigeri 5 months ago

  • Assignee deleted (intrigeri)

#19 Updated by intrigeri 5 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

#20 Updated by anonym 5 months ago

  • Status changed from Fix committed to Resolved

#21 Updated by anonym 5 months ago

  • Target version changed from Tails_3.13.2 to Tails_3.14

#22 Updated by intrigeri 4 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

Also available in: Atom PDF