Project

General

Profile

Bug #16653

feature/buster FTBFS since virtualbox was removed from testing and synaptic 0.84.6 was uploaded to sid

Added by intrigeri 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Virtualization
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
bugfix/16653-virtualbox-from-sid, https://salsa.debian.org/tails-team/tails/merge_requests/19
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

The build system tries to install the only version that's available & allowed by our APT pinning, i.e. currently: 5.2.12-dfsg-1 from our devel APT suite.

Our policy regarding VirtualBox support is essentially: install from sid as long as that's possible, then when it becomes impossible, import the latest working/installable version into our custom APT repo (that's how 5.2.12-dfsg-1 made it there in the first place), and if that doesn't work anymore, drop the ball and stop trying to install the VirtualBox packages unless there's a really cheap workaround.


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed 03/22/2019

Associated revisions

Revision 9b7b50e3 (diff)
Added by intrigeri 4 months ago

Enable the bugfix-16653-virtualbox-from-sid APT overlay (refs: #16653).

Revision 0c804b2e (diff)
Added by intrigeri 4 months ago

Install VirtualBox packages from sid (refs: #16653)

src:virtualbox was removed from testing.

Revision 40c5bb0a (diff)
Added by intrigeri 4 months ago

Refresh synaptic-update-at-startup.diff to apply on top of synaptic 0.84.6 (refs: #16653)

I'm patching only the X.Org-specific "else" clause: on Wayland,
Synaptic is start unprivileged so --update-at-startup would not work.

Revision da8f89e2
Added by segfault 4 months ago

Merge branch 'bugfix/16653-virtualbox-from-sid' into feature/buster (fix-committed: #16653)

History

#1 Updated by intrigeri 4 months ago

#2 Updated by intrigeri 4 months ago

  • Status changed from Confirmed to In Progress

#3 Updated by intrigeri 4 months ago

  • Feature Branch set to bugfix/16653-virtualbox-from-sid

#4 Updated by intrigeri 4 months ago

  • Subject changed from feature/buster FTBFS since virtualbox was removed from testing to feature/buster FTBFS since virtualbox was removed from testing and synaptic 0.84.6 was uploaded to sid

#6 Updated by intrigeri 4 months ago

  • Feature Branch changed from bugfix/16653-virtualbox-from-sid to bugfix/16653-virtualbox-from-sid, https://salsa.debian.org/tails-team/tails/merge_requests/19

#8 Updated by segfault 4 months ago

  • QA Check changed from Ready for QA to Pass

LGTM

#9 Updated by segfault 4 months ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 0 to 100

#10 Updated by intrigeri 3 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF