Project

General

Profile

Bug #16652

wireless unusable with rtl8723ae

Added by Jayz 3 months ago. Updated 2 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
Affected tool:

Description

constant dropouts on wifi and continuously asks for wifi password

tons of the following message on dmesg (is this related?)

Dropped outbound packet: IN= OUT=wlan0 SRC=fe80:0000:0000:0000:XXXX:XXXX:XXXX:XXXX DST=ff02:0000:0000:0000:0000:0000:0000:0002 LEN=48 TC=0 HOPLIMIT=255 FLOWLBL=XXXXX PROTO=ICMPv6 TYPE=133 CODE=0 UID=0 GID=0

this similar adapter is mentioned on known issues here https://tails.boum.org/support/known_issues/index.en.html#index17h2

all suggested combinations of startup options does not solve this issue

History

#1 Updated by jayz1 3 months ago

this message also appears constantly in the log

nl80211: send_and_recv->nl_recvmsgs failed: -33

is there an option to disable pci adapter entirely from startup options and use a usb adapter instead?

what other solutions can be for this whole issue?

#3 Updated by jayz1 3 months ago

behavior once connected to wifi network after multiple tries:

it connects to tor but after about 10 mins it stops creating new circuits and nothing shows in onion circuits although the interface is still connected to the network.

the only way to make it form new circuits is to disconnect and connect to wifi again.

#4 Updated by jayz1 3 months ago

modfying ant_sel like suggested for the BE model here https://tails.boum.org/support/known_issues/index.en.html#index17h2 does not work because:

kernel: rtl8723ae: unknown parameter 'ant_sel' ignored

#5 Updated by jayz1 3 months ago

I have to say again that I am not insisting on this model to work, I really dont care. But I want tails to work for me so if you can show me how to disable it completely and that this fixes the wifi issues then so be it.

The problem is now even with several USB adapters I tried on this machine the wifi still has many dropouts and problems. I dont know if rtl8723ae still interferes with usb adapters because I couldn't disable it.

There might be other issues here as well https://redmine.tails.boum.org/code/issues/16660

bottom line is tails is not really working for me at a bearable level

#6 Updated by mercedes508 3 months ago

Hi,

please send us a whisperback report so we can try to debug this, because we don't do individual support over redmine:

https://tails.boum.org/doc/first_steps/bug_reporting/#index3h1

Thanks.

#7 Updated by mercedes508 3 months ago

  • Assignee set to Jayz

#8 Updated by jayz1 3 months ago

mercedes508 wrote:

Hi,

please send us a whisperback report so we can try to debug this, because we don't do individual support over redmine:

https://tails.boum.org/doc/first_steps/bug_reporting/#index3h1

Thanks.

this is currently the only way I have I'm afraid. sorry about that.

I also checked these similar previous bugs on redmine https://redmine.tails.boum.org/code/issues/15070
https://redmine.tails.boum.org/code/issues/7071

and the 'known issues page'; on tails website

#9 Updated by mercedes508 3 months ago

If you just want to use Wi-Fi you can get another Wi-Fi adapater:

https://tails.boum.org/support/known_issues/#index3h1

#10 Updated by mercedes508 2 months ago

  • Status changed from New to Rejected

Closing it for now because of lack of answer from OP.

Also available in: Atom PDF