Project

General

Profile

Bug #16649

devel branch FTBFS: groupmod: GID '109' already exists

Added by intrigeri about 1 month ago. Updated 19 days ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/16649-render-group, https://salsa.debian.org/tails-team/tails/merge_requests/18
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed 03/22/2019

Associated revisions

Revision dd1f5be9 (diff)
Added by intrigeri about 1 month ago

Avoid new "render" group stealing a GID we have already statically allocated to another group (refs: #16649)

With the systemd 241-1~bpo9+1 → 241-3~bpo9+1 upgrade, udev.postinst
now creates a "render" system group, which shifts GIDs and makes
our devel branch FTBFS.

Revision d7d9e6ea (diff)
Added by intrigeri about 1 month ago

Avoid new "render" group stealing a GID we have already statically allocated to another group (refs: #16649)

With the systemd 241-1~bpo9+1 → 241-3~bpo9+1 upgrade, udev.postinst
now creates a "render" system group, which shifts GIDs and makes
our devel branch FTBFS.

Revision 99ce37e8
Added by anonym about 1 month ago

Merge remote-tracking branch 'origin/bugfix/16649-render-group' into devel

Fix-committed: #16649

Revision 000cf4f8 (diff)
Added by intrigeri 29 days ago

Avoid new "render" group stealing a GID we have already statically allocated to another group (refs: #16649)

With the systemd 241-1~bpo9+1 → 241-3~bpo9+1 upgrade, udev.postinst
now creates a "render" system group, which shifts GIDs and makes
our devel branch FTBFS.

History

#1 Updated by intrigeri about 1 month ago

#2 Updated by intrigeri about 1 month ago

That's caused by the udev upgrade that creates a render group.

#3 Updated by intrigeri about 1 month ago

  • Status changed from Confirmed to In Progress
  • Feature Branch set to bugfix/16649-render-group

#4 Updated by intrigeri about 1 month ago

  • Assignee deleted (intrigeri)
  • QA Check set to Ready for QA
  • Feature Branch changed from bugfix/16649-render-group to bugfix/16649-render-group, https://salsa.debian.org/tails-team/tails/merge_requests/18

Builds fine locally. Should not impact anything so skipping CI.

#5 Updated by intrigeri about 1 month ago

  • Priority changed from Normal to Elevated

#6 Updated by anonym about 1 month ago

  • Assignee set to anonym

#7 Updated by anonym about 1 month ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 0 to 100

#8 Updated by anonym about 1 month ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

LGTM! And builds! :) Merged!

#9 Updated by intrigeri 29 days ago

  • Status changed from Fix committed to In Progress

#10 Updated by intrigeri 29 days ago

  • Status changed from In Progress to Fix committed

#11 Updated by intrigeri 21 days ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

#12 Updated by anonym 19 days ago

  • Status changed from Fix committed to Resolved

#13 Updated by anonym 19 days ago

  • Target version changed from Tails_3.13.2 to Tails_3.14

#14 Updated by intrigeri 19 days ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

Also available in: Atom PDF