Project

General

Profile

Bug #16642

devel branch FTBFS: Electrum was removed from stretch-backports

Added by intrigeri 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
https://salsa.debian.org/tails-team/tails/merge_requests/11
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Electrum

Description

If we can install the version from sid, let's do it. Otherwise, let's import into our custom APT repo the latest version that we can install.


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed 03/22/2019

Associated revisions

Revision d909fa5b (diff)
Added by intrigeri 3 months ago

Install Electrum from sid (refs: #16642)

Electrum was removed from stretch-backports since it was auto-removed
(RC buggy) from testing.

Revision 3a27876c
Added by intrigeri 3 months ago

Merge branch 'bugfix/16642-electrum-from-sid' into devel (Closes: #16642)

Revision 529555d9 (diff)
Added by intrigeri 3 months ago

Install Electrum from sid (refs: #16642)

Electrum was removed from stretch-backports since it was auto-removed
(RC buggy) from testing.

History

#1 Updated by intrigeri 3 months ago

#2 Updated by intrigeri 3 months ago

  • Status changed from Confirmed to In Progress

#3 Updated by intrigeri 3 months ago

  • Feature Branch set to bugfix/16642-electrum-from-sid

I've installed 3.2.3-1 from sid and as expected, it fails to connect most of the time (known issue: #16421). When I start it, I see a dialog that suggests I send a bug report with the following content:

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/electrum/util.py", line 882, in run_with_except_hook
    run_original(*args2, **kwargs2)
  File "/usr/lib/python3/dist-packages/electrum/network.py", line 1085, in run
    self.wait_on_sockets()
  File "/usr/lib/python3/dist-packages/electrum/network.py", line 1067, in wait_on_sockets
    self.process_responses(interface)
  File "/usr/lib/python3/dist-packages/electrum/network.py", line 719, in process_responses
    self.process_response(interface, response, callbacks)
  File "/usr/lib/python3/dist-packages/electrum/network.py", line 646, in process_response
    if error is None and result > 0:
TypeError: unorderable types: NoneType() > int()

I'm not going to block on this here: given our next major release (Oct 22) will most likely be 4.0, based on Buster, our devel branch is currently only useful to identify early issues that will hit us when we'll bump the version of the APT snapshots used on our stable branch.

#4 Updated by intrigeri 3 months ago

  • Assignee deleted (intrigeri)
  • QA Check set to Ready for QA
  • Feature Branch changed from bugfix/16642-electrum-from-sid to https://salsa.debian.org/tails-team/tails/merge_requests/11

@hefee, @lamby, any taker?

#5 Updated by lamby 3 months ago

Apologies; I won't be able to review this in-depth.

#6 Updated by hefee 3 months ago

  • Assignee set to hefee

#7 Updated by hefee 3 months ago

intrigeri wrote:

I've installed 3.2.3-1 from sid and as expected, it fails to connect most of the time (known issue: #16421). When I start it, I see a dialog that suggests I send a bug report with the following content:

[...]

I'm not going to block on this here: given our next major release (Oct 22) will most likely be 4.0, based on Buster, our devel branch is currently only useful to identify early issues that will hit us when we'll bump the version of the APT snapshots used on our stable branch.

Sounds like we should create a ticket about this issue, so we don't forget about it, when we update Electrum in October.

#8 Updated by intrigeri 3 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

#9 Updated by intrigeri 3 months ago

hefee wrote:

intrigeri wrote:

When I start it, I see a dialog that suggests I send a bug report with the following content: [...]

Sounds like we should create a ticket about this issue, so we don't forget about it, when we update Electrum in October.

I was going to file a ticket but:

  • I can't reproduce this on feature/buster so I suspect a dependency should be versioned and the problem is Stretch-only. There's a good chance our October release is based on Buster so it won't be affected.
  • Even if our October release is 3.17 (Stretch): the test suite covers this and Electrum is mostly unusable currently anyway (someone will need to do something about it™ so we can keep shipping it and thus they'll need to test stuff); so I don't think we can possibly forget about it :)

#10 Updated by intrigeri 3 months ago

  • Assignee deleted (hefee)
  • QA Check changed from Ready for QA to Pass

#11 Updated by intrigeri 3 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

#12 Updated by anonym 3 months ago

  • Target version changed from Tails_3.13.2 to Tails_3.14

#13 Updated by intrigeri 3 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

Also available in: Atom PDF