Project

General

Profile

Bug #16628

Remove caribou

Added by alant 5 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
bugfix/16756-fix-on-screen-keyboard-in-thunderbird-and-remove-caribou
Type of work:
Code
Blueprint:
Starter:
Affected tool:
On-screen keyboard

Description

gnome-shell has no support for caribou since 3.28 and uses ibus-gtk3 for Screen Keyboard. We may consider dropping caribou and libcaribou*. We must check support in Tor Browser and GTK2 applications.


Related issues

Related to Tails - Feature #8281: Consider replacing Florence with GNOME's own on-screen keyboard Resolved 11/20/2014
Related to Tails - Bug #16757: Remove tails-greeter's dependency on libcaribou-gtk3-module Resolved
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed 03/22/2019
Blocked by Tails - Bug #16756: The on-screen keyboard does not work in Thunderbird on feature/buster (regression) Resolved

Associated revisions

Revision 03b5d914 (diff)
Added by intrigeri 3 months ago

Stop installing caribou and libcaribou*: they're not used by GNOME Shell in Buster anymore (refs: #16628)

Revision fbb9cbf4
Added by intrigeri 3 months ago

Merge branch 'bugfix/16756-fix-on-screen-keyboard-in-thunderbird-and-remove-caribou' into feature/buster

Closes: #16756, #16628

History

#1 Updated by intrigeri 5 months ago

#2 Updated by intrigeri 3 months ago

  • Affected tool set to On-screen keyboard

#3 Updated by intrigeri 3 months ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • Type of work changed from Research to Test

I'll test this.

#4 Updated by intrigeri 3 months ago

  • Related to Feature #8281: Consider replacing Florence with GNOME's own on-screen keyboard added

#5 Updated by intrigeri 3 months ago

  • Blocked by Bug #16756: The on-screen keyboard does not work in Thunderbird on feature/buster (regression) added

#6 Updated by intrigeri 3 months ago

After removing caribou-related packages from config/chroot_local-packageslists/tails-common.list, libcaribou-gtk3-module is installed anyway, and then the on-screen keyboard still works fine in GEdit, Tor Browser, and OnionShare. But it doesn't work in Thunderbird (no AppArmor denial in the logs). But actually, it doesn't work in Thunderbird at d7747a0555fea7af2a0c4ba2604d8a3f63c3f315 either, with all the caribou packages installed, so removing packages did not cause the problem => filed #16756 about it. Let's fix that problem before removing stuff.

#7 Updated by intrigeri 3 months ago

  • Related to Bug #16757: Remove tails-greeter's dependency on libcaribou-gtk3-module added

#8 Updated by intrigeri 3 months ago

libcaribou-gtk3-module is pulled in as a dependency of tails-greeter (#11430). Removing it now will be a pain since we don't build a Buster-specific version of tails-greeter yet => filed #16757 to track this follow-up. Let's focus this ticket on what can easily be removed already.

#9 Updated by intrigeri 3 months ago

  • Feature Branch set to bugfix/16756-fix-on-screen-keyboard-in-thunderbird-and-remove-caribou

#10 Updated by intrigeri 3 months ago

  • Subject changed from Consider removing caribou to Remove caribou
  • Assignee deleted (intrigeri)
  • QA Check set to Ready for QA
  • Type of work changed from Test to Code

On-screen keyboard on this branch works in Tor Browser, Thunderbird, Gedit, OnionShare.

#11 Updated by hefee 3 months ago

  • Assignee set to hefee

#12 Updated by hefee 3 months ago

  • QA Check changed from Ready for QA to Pass

seems fine.

#13 Updated by hefee 3 months ago

  • Assignee changed from hefee to intrigeri

#14 Updated by intrigeri 3 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF