Project

General

Profile

Bug #16615

Decide what to do wrt. Synaptic

Added by CyrilBrulebois 5 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

The synaptic package manager was recently removed from buster: https://tracker.debian.org/news/1037065/synaptic-removed-from-testing/

This is due to a series of RC bug reports:

All of those are mostly about synaptic's failure to work under Wayland. This has to be confirmed, but discussions during the BSP at Mozilla's seemed to indicate we might get synaptic back in testing (in time for buster).

For now, it's getting pulled from sid so that we can build and test the feature/buster branch; of course it's possible to adapt ASP to use a different package manager, but that might require more than the few minutes just spent implementing the change to config/chroot_apt/preferences


Related issues

Related to Tails - Feature #15262: GNOME Software Needs Validation 03/18/2017
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed 03/22/2019

Associated revisions

Revision 719714b5 (diff)
Added by CyrilBrulebois 5 months ago

Install synaptic from sid (refs: #16615).

It's been (hopefully temporarily) removed from testing; let's install it
from unstable, at least for the time being.

Revision 19278ab9 (diff)
Added by intrigeri 3 months ago

Revert "Install synaptic from sid" (Closes: #16615)

synaptic is back in testing since a month and there's no indication it'll be
removed again from Buster.

This reverts commit 719714b5cabeea1865fe94fda2b23c42b5218221.

History

#1 Updated by CyrilBrulebois 5 months ago

  • Status changed from Confirmed to In Progress

#2 Updated by intrigeri 5 months ago

#3 Updated by intrigeri 5 months ago

  • Subject changed from Make sure synaptic comes back into buster, or migrate away from it to Decide what to do wrt. Synaptic

#4 Updated by intrigeri 5 months ago

#5 Updated by intrigeri 5 months ago

  • Category deleted (Build system)
  • Affected tool set to Additional Software Packages

#6 Updated by intrigeri 3 months ago

  • Assignee set to intrigeri

synaptic is back in testing since a month and there's no indication it'll be removed again.

#7 Updated by intrigeri 3 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF