Project

General

Profile

Bug #16607

FTBFS with "repository '/amnesia.git/.git/modules/submodules/aufs4-standalone' does not exist"

Added by segfault 10 months ago. Updated 6 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Build system
Target version:
Start date:
03/23/2019
Due date:
% Done:

100%

Feature Branch:
feature/15342-cache-wiki
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Today when I tried to build devel it failed with

+ git clone --shared /amnesia.git/.git/modules/submodules/aufs4-standalone
fatal: repository '/amnesia.git/.git/modules/submodules/aufs4-standalone' does not exist

I was able to fix it by changing the permission of the submodules directories and the parent directories from 700 to 755:

chmod 755 .git/modules .git/modules/submodules .git/modules/submodules/*

This seems to be caused by df8a338ea6e078113ef6a03d7e3fbb3ffc7467d1. We should somehow make sure that the vagrant user actually has read access to the submodules directory. I don't know why it had permission 700 on my system.


Related issues

Related to Tails - Bug #16476: Allow building a branch using unpublished Git submodule changes Resolved 02/21/2019
Related to Tails - Bug #17289: FTBFS: git submodules Resolved
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision 32b1ac98 (diff)
Added by intrigeri 19 days ago

Build system: set the permissions that Vagrant needs inside the source tree (refs: #11411, #16607, #17289)

Revision 6684a825 (diff)
Added by intrigeri 19 days ago

Build system: abort early if the permissions on one of the parent directories are too strict (refs: #11411, #16607, #17289)

Revision f5c75d4e
Added by intrigeri 6 days ago

Merge branch 'feature/15342-cache-wiki' into stable (Closes: #15342, #17288, #16607, #17289, #11411)

History

#1 Updated by segfault 10 months ago

I'm having this issue repeatedly, the permissions are somehow changed between builds. I didn't spend any time trying to debug this. My revised command to fix this is

chmod -R go+rX .git/modules/submodules

#2 Updated by intrigeri 10 months ago

  • Related to Bug #16476: Allow building a branch using unpublished Git submodule changes added

#3 Updated by intrigeri 10 months ago

Indeed, looks like #16476 caused this regression. Perhaps our Rakefile should set the permissions that the rest of our build system needs.

#4 Updated by intrigeri 10 months ago

  • Category set to Build system

#5 Updated by intrigeri 9 months ago

#6 Updated by intrigeri about 1 month ago

  • Related to Bug #17289: FTBFS: git submodules added

#7 Updated by intrigeri 19 days ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • Feature Branch set to feature/15342-cache-wiki

#8 Updated by intrigeri 18 days ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (intrigeri)
  • Target version set to Tails_4.2

#9 Updated by intrigeri 14 days ago

  • Target version changed from Tails_4.2 to Tails_4.3

#10 Updated by segfault 11 days ago

  • Assignee set to segfault

#11 Updated by intrigeri 6 days ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF