Project

General

Profile

Bug #16570

Fix the secure Thunderbird autoconfig wizard patchset

Added by intrigeri 6 months ago. Updated 6 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
03/18/2019
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:
Email Client

Description

Something is wrong with the secure autoconfig wizard in 60.5.1-1~deb9u1.0tails1: #16422#note-24. Initial testing results suggest that there is a bug in Thunderbird itself and another one in our patchset.

It might be that a newer Thunderbird (60.6 or 66) would fix it.


Related issues

Related to Tails - Bug #16422: Upgrade Thunderbird to 60.5.1 Resolved 02/05/2019
Blocks Tails - Feature #15507: Core work 2019Q1: Foundations Team Resolved 04/08/2018

History

#1 Updated by intrigeri 6 months ago

  • Related to Bug #16422: Upgrade Thunderbird to 60.5.1 added

#2 Updated by intrigeri 6 months ago

#3 Updated by intrigeri 6 months ago

  • Feature Branch set to bugfix-16422-thunderbird-60.5.1, icedove:bugfix/16422-thunderbird-60.5.1

#4 Updated by intrigeri 6 months ago

anonym wrote (on #16422):

intrigeri wrote:

Will now test manually with & without persistence, using a non-Riseup email account

CyrilBrulebois, unfortunately I see a regression in the account wizard. I first see "Configuration found at email provider" with correct settings, so far so good; on Tails 3.12.1 the wizard would (correctly) stop here. But on this branch, then the wizard keeps trying other things (at least "Looking up configuration: Trying common server names") and ends up telling me "Thunderbird failed to find the settings for your email account" and pre-filling the config settings with imap.$DOMAIN and smtp.$DOMAIN, that won't work in this case.

I noticed this myself when I was rebasing and partly rewriting the patch set for Thunderbird 66 but only in a odd edge case: I tested against ProtonMail whose config points to servers at 127.0.0.1 (I suppose you are supposed to run some local proxy to ProtonMail). Thunderbird would consider it a success in the GUI as soon as a valid config is fetched, but would fail after a few seconds when it tries the config (since we don't run any mail servers on 127.0.0.1 and even block any such connection attempt), and then fallback to the remaining auto-config methods that still are running in the background. The fix is to no consider a config successful (not even in the GUI!) until it has been tested.

Care to share which service you tried with so I can investigate if it's similar?

Will do privately.

#5 Updated by intrigeri 6 months ago

  • Subject changed from Try to fix and ship the secure Thunderbird autoconfig wizard patchset to Fix the secure Thunderbird autoconfig wizard patchset

#6 Updated by anonym 6 months ago

  • Status changed from Confirmed to Rejected
  • Target version deleted (Tails_3.14)
  • Parent task deleted (#6156)
  • Feature Branch deleted (bugfix-16422-thunderbird-60.5.1, icedove:bugfix/16422-thunderbird-60.5.1)

It doesn't look like the patches are the cause. Rejecting in favor of #16573.

Also available in: Atom PDF