Project

General

Profile

Bug #16542

Refresh ikiwiki wrappers when ikiwiki.setup.erb is updated

Added by intrigeri 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Infrastructure
Target version:
Start date:
03/07/2019
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

As seen on #16483#note-9, some changes to ikiwiki.setup deployed via Puppet (templates/website/ikiwiki.setup.erb) are not fully applied until a sysadmin manually runs ikiwiki with the --wrappers option. Like any "after X one must do Y by hand", even if that was documented, we're bound to forget it occasionally. Let's instead teach Puppet to do that itself automatically :)


Related issues

Related to Tails - Feature #16483: Publish our personas on our website Resolved 02/24/2019
Related to Tails - Feature #14588: Self-host our website Resolved 10/03/2018
Blocks Tails - Feature #13284: Core work: Sysadmin (Adapt our infrastructure) Confirmed 06/30/2017

History

#1 Updated by intrigeri 2 months ago

  • Related to Feature #16483: Publish our personas on our website added

#2 Updated by intrigeri 2 months ago

  • Blocks Feature #13284: Core work: Sysadmin (Adapt our infrastructure) added

#3 Updated by intrigeri 2 months ago

@bertagaz, since you've been the one directly affected by this problem, I would appreciate if you could take a quick look at the problem statement and proposed solution in the ticket description. Thanks in advance!

#4 Updated by intrigeri 2 months ago

#5 Updated by intrigeri 2 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to groente
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

Done, seems to work: the /srv/tails.boum.org/html/ikiwiki.cgi ikiwiki wrapper got updated after I've manually modified a comment in /srv/tails.boum.org/config/ikiwiki.setup and run the Puppet agent again, that realized it had to update ikiwiki.setup, and in turn has updated the ikiwiki wrapper as expected.

@groente, please review https://git-tails.immerda.ch/puppet-tails/commit/?id=1bb84dbf9bf9d3de6fd42c137e805ef683a012fd and https://git-tails.immerda.ch/puppet-tails/commit/?id=101b9ac25fef17af358001ecbe590cb0c7205648

#6 Updated by groente 2 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

Also available in: Atom PDF