Project

General

Profile

Feature #16504

Document how to request budget for a sprint

Added by Anonymous about 1 year ago. Updated 29 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Project
Target version:
Start date:
03/01/2019
Due date:
% Done:

0%

Feature Branch:
https://tails.boum.org/contribute/sprint/
Type of work:
Accounting
Blueprint:
Starter:
Affected tool:
Handbook

Description

this can be public.


Related issues

Related to Tails - Bug #16505: Document travel reimbursements Duplicate 03/01/2019

Associated revisions

Revision 7c2d1026 (diff)
Added by intrigeri about 2 months ago

Document how to request budget for a sprint (refs: #16504)

Revision df9601ca (diff)
Added by intrigeri about 1 month ago

Sprint: point to doc wrt. food budget (refs: #16504)

Revision 5a59f2ba (diff)
Added by intrigeri about 1 month ago

Sprint: clarify how reimbursements are processed (refs: #16504)

Revision 1a6d8349 (diff)
Added by intrigeri about 1 month ago

Sprint: add missing requested info (refs: #16504)

Revision 757d471a (diff)
Added by intrigeri about 1 month ago

Sprint: add example (refs: #16504)

Revision 9ec97bc0 (diff)
Added by intrigeri about 1 month ago

Sprint: clarify recommended order to do things (refs: #16504)

Revision 4c2aa4b3 (diff)
Added by intrigeri about 1 month ago

Sprint: make it explicit that the earlier, the better (refs: #16504)

Revision e7d1b141 (diff)
Added by intrigeri about 1 month ago

Sprint: move example closer to where it's needed + make it an actual example (refs: #16504)

Revision 75c8b030 (diff)
Added by intrigeri about 1 month ago

Sprint: add missing info to example (refs: #16504)

Revision b72a7e55 (diff)
Added by intrigeri about 1 month ago

Sprint sponsorship request: explicitly suggest adding a safety margin (refs: #16504)

Otherwise, to some newcomers it feels like they're not allowed to make mistakes,
which is stressful. That problem is made worse by the fact we have no explicitly
documented mechanism to deal with sprint budget overflows.

Credits go to hefee for the feedback that lead to this commit.

Revision 1c44edaf (diff)
Added by intrigeri about 1 month ago

Sprint: explicitly mention a mechanism to handle budget overflows (refs: #16504)

Revision 6cae897c (diff)
Added by intrigeri about 1 month ago

Reimbursements: don't suggest that we'll need all receipts (refs: #16504)

The reviewer (hefee) pointed out that the way this was phrased previously
was stricter than our actual rules, which is confusing.

Also, it could lead people to not include in the sponsorship request some
expenses because they would be mistakenly lead to believe that they would not be
able to get them reimbursed.

History

#2 Updated by Anonymous about 1 year ago

  • Related to Bug #16505: Document travel reimbursements added

#3 Updated by sajolida 8 months ago

  • Affected tool set to Handbook

#4 Updated by sajolida 8 months ago

  • Affected tool deleted (Handbook)

#5 Updated by Anonymous 7 months ago

  • Assignee set to Anonymous

#6 Updated by sajolida 3 months ago

  • Assignee deleted (Anonymous)
  • Affected tool set to Handbook

#7 Updated by intrigeri about 2 months ago

  • Subject changed from Document how to request sprint budgets to Document how to request budget for a sprint
  • Assignee set to intrigeri
  • Target version set to Tails_4.4

I'll try to do this soon, so that someone else than me can do user testing of the new doc, by asking budget for the upcoming FT sprint :)

#8 Updated by intrigeri about 2 months ago

  • Status changed from Confirmed to In Progress

#9 Updated by intrigeri about 2 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from intrigeri to hefee
  • Feature Branch set to https://tails.boum.org/contribute/sprint/

Hi @hefee,

Context: this ticket is part of an effort (ongoing since a few years on the accounting team) to incrementally document our existing collective processes.

Usually I would request a review from another accounting team member, but this time I think we have the opportunity to do better: how about you test this doc by doing the sponsorship request for the upcoming FT & GitLab sprints yourself? (Please clock this work as FT.)

If you're fine with that: please let me know if anything is missing, unclear, or feels wrong :)

#10 Updated by hefee about 1 month ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from hefee to intrigeri
The document does not answer:
  • When I should do the sponsorship request? As fast as possible (more estimate but more early) or precise as possible (only short before the sprint).
  • For the FT sprint, I don't know if I should now sent a (first) request and updates later on or only if I know the travel costs by everyone?
  • Or should I estimate them, but what should I use as base?
  • What happens if I estimate wrong?
  • Do I need to do two sponsorship requests for Gitlab and FT sprint (as it is the same location)?
  • Do I need to send receipts/bills to accounting or anyone else?
  • Do I need to coordinate the reimbursement for every attendee?
  • What is the process of updating the sponsorship request?
  • An example would be nice, how this request may look like.

#11 Updated by intrigeri about 1 month ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from intrigeri to hefee

Hi!

First, thanks for this careful review!

  • When I should do the sponsorship request? As fast as possible (more estimate but more early) or precise as possible (only short before the sprint).

Fixed.

  • For the FT sprint, I don't know if I should now sent a (first) request and updates later on or only if I know the travel costs by everyone?

Please first gather the data, then send the request once you have everything you need in order to follow this doc & provide the requested info.
I've clarified this in the doc.

  • Or should I estimate them, but what should I use as base?

So far, we've generally avoided estimating travel costs for other people: different people have different needs & preferences, so it's too hard to get it right.

  • What happens if I estimate wrong?

I don't know: IIRC we've never exceeded budget for a sprint and AFAIK we have no rule/process about this, so this probably boils down to "as for any corner case, we'll have to talk about it".

Note that the request is about the maximum budget. Usually we include some safety margin to every number that may change, to be on the safe side. That's simpler for everyone involved than trying to be accurate and then having to deal with budget overflows.

  • Do I need to do two sponsorship requests for Gitlab and FT sprint (as it is the same location)?

It's vastly simpler for you to send a single request (otherwise you'll have to figure out how to split the travel costs for folks who attend both, factoring in the fact that per-sprint budgets would depend on whether 1 or 2 of the requests are approved; I would definitely not even try!).

I'm not sure this corner case is worth making the doc more complicated for everyone else. If you disagree, I'll document it.

  • Do I need to send receipts/bills to accounting or anyone else?

I'm afraid I don't understand what's missing in the "How do we get actually reimbursed?" section.
Could you please clarify?

(Rationale: I'd like to add only the critically missing info here, without having to document the full reimbursement process on that page, since that's beyond the scope of this ticket and web page).

  • Do I need to coordinate the reimbursement for every attendee?

Thankfully, no :) I've clarified the doc a bit.

  • What is the process of updating the sponsorship request?

There's no process I'm aware of apart of replying to your initial request to update it (following basically the same doc).
Do you think it's worth documenting?

  • An example would be nice, how this request may look like.

Done!

#12 Updated by intrigeri about 1 month ago

  • Or should I estimate them, but what should I use as base?

So far, we've generally avoided estimating travel costs for other people: different people have different needs & preferences, so it's too hard to get it right.

Oh my, sorry, I realize that was stupid of me: when I prepare a sponsorship request, pretty often I do estimate travel costs for other attendees.
I don't know about a base one can use.
For flights, I use https://www.kayak.com/ or Google Flights.
For train, I use https://www.thetrainline.com/.

#13 Updated by hefee about 1 month ago

intrigeri wrote:

  • What happens if I estimate wrong?

I don't know: IIRC we've never exceeded budget for a sprint and AFAIK we have no rule/process about this, so this probably boils down to "as for any corner case, we'll have to talk about it".

Note that the request is about the maximum budget. Usually we include some safety margin to every number that may change, to be on the safe side. That's simpler for everyone involved than trying to be accurate and then having to deal with budget overflows.

You know, because of history, that you never made a mistake, but for new people like me there is a big uncertainty, if I forgot anything. So if this document should encourage new people to do the sponsorship request, it would be helpful, to know that mistakes may happen and how to handle mistakes. Because mistakes will happen! Maybe a good idea would be to write that new people should request X% more than they have calculated (X maybe 30-50). Just to be super sure that the maximum budget is ok. At least for me I feel a lot stress, because it feels that I am not allowed to do mistakes and this is not a good way to learn something.

  • Do I need to do two sponsorship requests for Gitlab and FT sprint (as it is the same location)?

It's vastly simpler for you to send a single request (otherwise you'll have to figure out how to split the travel costs for folks who attend both, factoring in the fact that per-sprint budgets would depend on whether 1 or 2 of the requests are approved; I would definitely not even try!).

I'm not sure this corner case is worth making the doc more complicated for everyone else. If you disagree, I'll document it.

no it is fine to keep the document simple.

  • Do I need to send receipts/bills to accounting or anyone else?

I'm afraid I don't understand what's missing in the "How do we get actually reimbursed?" section.
Could you please clarify?

(Rationale: I'd like to add only the critically missing info here, without having to document the full reimbursement process on that page, since that's beyond the scope of this ticket and web page).

The section is very strict: I interpret it like: only money if you have a receipt.

But you handled is different in the past (for food receipts) and that it is often hard to get a receipt for everything. That's why I think, the section should mention the case, when you forgot to get a receipt for something. At least in my case I get (travel) food by people and give them a donation for it without any receipt.

#14 Updated by intrigeri about 1 month ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from hefee to intrigeri

Thanks a lot @hefee! I'll rework the doc right away.

#15 Updated by intrigeri about 1 month ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from intrigeri to hefee
  • Target version changed from Tails_4.4 to Tails_4.5

Hi again @hefee,

hefee wrote,

intrigeri wrote:

  • What happens if I estimate wrong?

I don't know: IIRC we've never exceeded budget for a sprint and AFAIK we have no rule/process about this, so this probably boils down to "as for any corner case, we'll have to talk about it".

Note that the request is about the maximum budget. Usually we include some safety margin to every number that may change, to be on the safe side. That's simpler for everyone involved than trying to be accurate and then having to deal with budget overflows.

You know, because of history, that you never made a mistake, but for new people like me there is a big uncertainty, if I forgot anything. So if this document should encourage new people to do the sponsorship request, it would be helpful, to know that mistakes may happen and how to handle mistakes. Because mistakes will happen! Maybe a good idea would be to write that new people should request X% more than they have calculated (X maybe 30-50). Just to be super sure that the maximum budget is ok. At least for me I feel a lot stress, because it feels that I am not allowed to do mistakes and this is not a good way to learn something.

I hear and understand what you're saying. I'm sorry that my attempt to reassure you had the opposite effect of what I intended :(
I agree that mistakes happen. I did a bunch of mistakes myself in this area.

I think there are two aspects:

  • IMO we should lower the risk that a mistake in the sponsorship request triggers a budget overflow ⇒ lower the chances we need to go through extra process steps to handle exceptions. I like your idea to explicitly suggest adding a safety margin ⇒ what do you think about b72a7e55f335f22f40a002eac16a9a14ef95ac7a ?
  • What happens if, despite the safety margin, for whatever reason a sprint overflows its budget? This may be caused by a mistake in the sponsorship request, by unpredictable external factors, etc.
    • We have a mechanism for a similar case ("If a budget runs out") documented in summit.git:Handbook/Timesheets_and_budget_management.mdwn.
    • There's been a proposal on the -summit mailing list to apply this existing mechanism, until we set up something better, to another, similar situation. I think the case we're discussing here should be explicitly covered just the same in our internal doc.
    • I'm not sure how to best handle the separation between public doc (that's what this ticket is about) and internal doc.
    • For now, I did 1c44edaf0235dd0c1fd633637df977e2f731e408, which may be insufficient but at least it opens the door to the possibility to talk about it if we're in a corner case that our rules don't cover. Good enough for the time being?
  • Do I need to send receipts/bills to accounting or anyone else?

I'm afraid I don't understand what's missing in the "How do we get actually reimbursed?" section.
Could you please clarify?

(Rationale: I'd like to add only the critically missing info here, without having to document the full reimbursement process on that page, since that's beyond the scope of this ticket and web page).

The section is very strict: I interpret it like: only money if you have a receipt.

But you handled is different in the past (for food receipts) and that it is often hard to get a receipt for everything. That's why I think, the section should mention the case, when you forgot to get a receipt for something. At least in my case I get (travel) food by people and give them a donation for it without any receipt.

Ah, OK, I see! Thank you for clarifying.

It's true that our detailed internal rules to handle receipts are less strict than what this section currently suggests.
Publishing all these rules would have far reaching implications that I don't think are acceptable by all stakeholders.
The accounting team normally sends these rules to every sprint attendee as soon as the sponsorship request is accepted, that is in most cases: before they spend money on behalf of Tails and have to worry about receipts. It may be that we occasionally forget this step, because we're humans and we make mistakes.

I've tried to fix this with 6cae897c0680c3f119c6793162524bc898125635. Better?

#16 Updated by hefee about 1 month ago

  • Status changed from Needs Validation to Resolved
  • Assignee deleted (hefee)

@intrigeri: I'm fine with the current status. So I mark this as resolved.

#17 Updated by intrigeri 29 days ago

  • Category set to Project

Also available in: Atom PDF