Project

General

Profile

Feature #16485

{live-media-encryption|encryption}=TYPE

Added by Anonymous 5 months ago. Updated about 2 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
02/26/2019
Due date:
% Done:

0%

Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
Affected tool:

Description

The only supported TYPE for this live-boot option is "aes" which refers to cryptoloop/loopaes and is deprecated.

We should have the ability to encrypt a USB device using LUKS (with detached header) or plain dm-crypt encryption, copy the Tails .iso over to it, and then boot off it. By adding "plain" or "luks" support for the above live-boot option, I believe this will be possible. The device can be mounted using gfxterm from a separate grub2 installation, whether from a coreboot BIOS or perhaps a decoy operating system.

This will provide plausible deniability for those who need to hide the fact that they use Tails/Tor.

I'm wondering if anyone else feels that this feature would be valuable.


Related issues

Related to Tails - Feature #5929: Consider creating a persistence by default for plausible deniability Confirmed 08/20/2016

History

#1 Updated by intrigeri 5 months ago

  • Related to Feature #5929: Consider creating a persistence by default for plausible deniability added

#2 Updated by intrigeri 5 months ago

  • Assignee set to Anonymous
  • QA Check set to Info Needed

If I got it right, the goal would be that a Tails USB stick would appear to be a LUKS device, with nothing Tails specific on it (no bootloader, no kernel, no initrd). Right?

At first glance, implementing this would be a huge project. I suspect its cost would immensely outweigh the amount of real-world use cases it would improve.

#3 Updated by Anonymous 5 months ago

Something like that. Except if there was support for plain dm-crypt mode then the Tails USB stick would appear to be filled with random data, since there is no header in plain mode. This is assuming that the USB stick was initialized properly (full random data overwrite before encryption).

#4 Updated by intrigeri about 2 months ago

  • QA Check deleted (Info Needed)

@sajolida, please triage this feature request :)

#5 Updated by sajolida about 2 months ago

  • Status changed from New to Rejected

Same as intrigeri on #note-2: I don't believe in the cost/benefit ratio of such a project.

Also available in: Atom PDF