Project

General

Profile

Bug #16469

devel branch FTBFS: linux-image-4.19.0-2-amd64 not available

Added by intrigeri 5 months ago. Updated 5 months ago.

Status:
Rejected
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
02/15/2019
Due date:
% Done:

100%

Feature Branch:
bugfix/16469-linux-4.19.0-3-devel+force-all-tests
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

… due to our APT pinning.


Related issues

Related to Tails - Bug #16458: Upgrade Linux to 4.19.20+ for Tails 3.13 Resolved 02/11/2019
Blocks Tails - Feature #15507: Core work 2019Q1: Foundations Team Resolved 04/08/2018

Associated revisions

Revision a54df078 (diff)
Added by intrigeri 5 months ago

Pin kernel packages from testing at the same level as those from sid (refs: #16469)

Currently, the kernel package we want to install (linux-image-4.19.0-2-amd64) is
still available in testing, but not in sid anymore. Let's pull it from wherever
it's available to reduce churn (we should upgrade to 4.19.0-3 but there's no big
hurry and we have #16458 to track this). APT should pull the newest version of
the package, i.e. the one from sid if it exists there and is newer.

Revision 7651d94c (diff)
Added by intrigeri 5 months ago

Upgrade Linux to 4.19.0-3 from sid, currently at 4.19.20-1 (refs: #16469)

Revision c7bf1c23 (diff)
Added by intrigeri 5 months ago

Upgrade Linux to 4.19.0-3 from sid, currently at 4.19.20-1 (refs: #16469)

History

#1 Updated by intrigeri 5 months ago

#2 Updated by intrigeri 5 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/16469-fetch-desired-kernel-from-wherever-it-is-available

#3 Updated by intrigeri 5 months ago

  • Feature Branch deleted (bugfix/16469-fetch-desired-kernel-from-wherever-it-is-available)

Gah, my approach won't work as we don't include the Buster APT sources. Including them would make UX worse (at least for users who use Additional Software) so IMO the minor dev workflow improvement brought by my proposed approach is not worth it. I'll fall back to upgrading to ABI 3 on devel, which will give us data points for #16458.

#4 Updated by intrigeri 5 months ago

  • Related to Bug #16458: Upgrade Linux to 4.19.20+ for Tails 3.13 added

#5 Updated by intrigeri 5 months ago

  • Feature Branch set to bugfix/16469-linux-4.19.0-3-devel+force-all-tests

#6 Updated by intrigeri 5 months ago

  • Assignee deleted (intrigeri)
  • QA Check set to Ready for QA

#7 Updated by intrigeri 5 months ago

  • Assignee set to intrigeri

#8 Updated by intrigeri 5 months ago

  • Blocks Bug #16462: Upgrade to Stretch 9.8 in Tails 3.13 added

#9 Updated by intrigeri 5 months ago

https://jenkins.tails.boum.org/job/test_Tails_ISO_bugfix-16469-linux-4.19.0-3-devel-force-all-tests/1/cucumberTestReport/ only has expected failures. Next step: test on bare metal. Feel free to steal it from me as part of the review.

#10 Updated by intrigeri 5 months ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 10 to 50

Boots, connects to Wi-Fi, loads Tor Browser, shutdowns on boot medium removal on HP EliteBook 840G1 and ThinkPad X200.

⇒ @anonym, please review and merge into devel.

#11 Updated by intrigeri 5 months ago

If this is not merged today, then perhaps hold on a bit: I'm preparing the same change for our stable branch on #16458 and #16462.

#12 Updated by intrigeri 5 months ago

… so I would suggest you first review the branches that are not about upgrading the kernel.

#13 Updated by intrigeri 5 months ago

  • Blocks deleted (Bug #16462: Upgrade to Stretch 9.8 in Tails 3.13)

#14 Updated by intrigeri 5 months ago

  • Status changed from In Progress to Rejected
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check deleted (Ready for QA)

Obsoleted by #16458.

Also available in: Atom PDF