Project

General

Profile

Bug #16462

Upgrade to Stretch 9.8 in Tails 3.13

Added by intrigeri 10 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
02/13/2019
Due date:
% Done:

100%

Feature Branch:
bugfix/16462-16458-stretch-9.8-linux-4.19.20+force-all-tests
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

It's scheduled for Saturday, February 16th, 2019: https://release.debian.org/proposed-updates/stable.html


Related issues

Blocks Tails - Feature #15507: Core work 2019Q1: Foundations Team Resolved 04/08/2018
Blocks Tails - Bug #16458: Upgrade Linux to 4.19.20+ for Tails 3.13 Resolved 02/11/2019

Associated revisions

Revision e980eb74 (diff)
Added by intrigeri 10 months ago

Upgrade to Debian Stretch 9.8 (refs: #16462).

Revision d72efd1f
Added by anonym 10 months ago

Merge remote-tracking branch 'origin/bugfix/16462-16458-stretch-9.8-linux-4.19.20+force-all-tests' into stable

Fix-committed: #16462, #16458

History

#1 Updated by intrigeri 10 months ago

#2 Updated by intrigeri 10 months ago

  • Blocked by Bug #16469: devel branch FTBFS: linux-image-4.19.0-2-amd64 not available added

#3 Updated by intrigeri 10 months ago

(The easiest way to evaluate this will be to look at how devel behaves, since it'll pick up the point release automatically.)

#4 Updated by intrigeri 10 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

I've quickly reviewed the list of "processed" (= accepted) packages on https://release.debian.org/proposed-updates/stable.html and tl;dr: the cups and glibc security updates (that got no DSA) would be nice to have.

#5 Updated by intrigeri 10 months ago

  • Blocks Bug #16458: Upgrade Linux to 4.19.20+ for Tails 3.13 added

#6 Updated by intrigeri 10 months ago

  • % Done changed from 10 to 20

I've compared the .packages file between 3.12.1 and bugfix/16469-linux-4.19.0-3-devel+force-all-tests at 8a9e266119c17531670e5f66d3a25d7134f4d7a5 (i.e. devel, that picked up Stretch 9.8 already, plus the kernel update that it needs to build) and I could spot nothing particularly scary or unexpected. Will run the full test suite on it locally as Jenkins is broken since the reboot yesterday.

#7 Updated by intrigeri 10 months ago

  • Blocks deleted (Bug #16458: Upgrade Linux to 4.19.20+ for Tails 3.13)

#8 Updated by intrigeri 10 months ago

  • Subject changed from Consider upgrading to Stretch 9.8 in Tails 3.x to Upgrade to Stretch 9.8 in Tails 3.13
  • Type of work changed from Research to Code

intrigeri wrote:

Will run the full test suite on it locally as Jenkins is broken since the reboot yesterday.

A few fragile tests failed plus a couple temporary network issues. Seems OK, will prepare a branch based on stable.

#9 Updated by intrigeri 10 months ago

  • Feature Branch set to bugfix/16462-16458-stretch-9.8-linux-4.19.20+force-all-tests

#10 Updated by intrigeri 10 months ago

  • Blocks Bug #16458: Upgrade Linux to 4.19.20+ for Tails 3.13 added

#11 Updated by intrigeri 10 months ago

  • Blocked by deleted (Bug #16469: devel branch FTBFS: linux-image-4.19.0-2-amd64 not available)

#12 Updated by intrigeri 10 months ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 20 to 50
  • QA Check set to Ready for QA

Full test suite passed locally except a few fragile tests: the MAC spoofing failure notifications (never seen them work reliably recently, #16420 and "Using Totem ǂ Watching a WebM video over HTTPS" which often fails these days).

@anonym please review and merge into stable. The branch covers this ticket and #16458.

#13 Updated by anonym 10 months ago

  • Status changed from In Progress to 11
  • % Done changed from 50 to 100

#14 Updated by anonym 10 months ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

Looks good! I've built stable with this branch merged, and then devel witht that stable merged, and we are indeed not FTBFS anymore! I mostly rely on your testing, though, as I only made sure the builds booted in VMs.

#15 Updated by intrigeri 10 months ago

Thanks! I've accordingly bumped the expiration date of the APT snapshots (both those updated by the branch you've merged and the other ones) so they're valid until after our next major release (Oct 22).

#16 Updated by CyrilBrulebois 9 months ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF