Project

General

Profile

Bug #16457

Building feature/buster in RAM sometimes fails: mksquashfs reaped by OOM killer

Added by intrigeri 2 months ago. Updated 20 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Build system
Target version:
Start date:
02/11/2019
Due date:
% Done:

0%

QA Check:
Pass
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

For context, initial analysis, and test results, see #16177.

Next steps:

  1. Verify that squashfs-tools 4.3-3.0tails4 does honor -mem consistently (I think I did already but let's be sure).
  2. Find out why squashfs-tools 4.3-11 does not honor -mem consistently, e.g.:
    1. Try to reproduce with pristine 4.3-3 changes
    2. Try reverting the 4.3-3..4.3-11 changes
    3. Try applying the patchset collected by lynxis on top of 4.3-11
  3. Report the bug, ideally with a patch attached.

Related issues

Related to Tails - Bug #16177: Building ISO in RAM often fails: mksquashfs reaped by OOM killer Resolved 12/02/2018
Related to Tails - Bug #16637: squashfs-tools from Buster (1:4.3-12) is much slower than 1:4.3-8.0tails1 Confirmed
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed 03/22/2019

Associated revisions

Revision 6370ba62 (diff)
Added by anonym 23 days ago

Pin our version of squashfs-tools.

At the moment we'd otherwise get Debian's newer 4.3-11 but on some
systems its mksquashfs gets OOM killed, so let's stick with a version
that doesn't break builds for now.

Refs: #16457

History

#1 Updated by intrigeri 2 months ago

#2 Updated by intrigeri 2 months ago

  • Description updated (diff)

#3 Updated by intrigeri 2 months ago

  • Subject changed from Building ISO in RAM sometimes fails: mksquashfs reaped by OOM killer to Building feature/buster in RAM sometimes fails: mksquashfs reaped by OOM killer

#4 Updated by intrigeri 2 months ago

  • Related to Bug #16177: Building ISO in RAM often fails: mksquashfs reaped by OOM killer added

#6 Updated by lamby about 1 month ago

This is https://bugs.debian.org/923711

Mon 18 14:22 <@lamby> Looks like something that could be handled under FT.
Mon 18 14:23 <@lamby> If so, I'll file an issue in Redmine
Mon 18 14:23 <======> lamby: I'd think so

#7 Updated by lamby about 1 month ago

  • Assignee set to lamby

#8 Updated by anonym 23 days ago

  • Status changed from Confirmed to In Progress

#9 Updated by lamby 21 days ago

This was fixed in:

 squashfs-tools (1:4.3-12) unstable; urgency=medium
 .
   [ Alexander Couzens <lynxis@fe80.eu> ]
   * Fix compressor initialization in frag_deflator() (closes: #923711).

I'm going to request an unblock for buster.

#10 Updated by lamby 21 days ago

Asked the maintainer whether I can ask for an unblock ask. https://bugs.debian.org/923711#98

#11 Updated by intrigeri 20 days ago

  • Type of work changed from Research to Wait

#12 Updated by lamby 20 days ago

  • Status changed from In Progress to Resolved

#13 Updated by intrigeri 20 days ago

  • Status changed from Resolved to In Progress

1:4.3-12 was uploaded to sid […] and was unblocked for buster:

Woohoo!

Resolving to match.

I think we'll need to revert 6370ba62f331a6c715cbcdb625f4b9a5f7af13a4 in order to switch to this new, unblocked version (otherwise we're stuck with a temporary workaround).

#14 Updated by intrigeri 20 days ago

  • Assignee deleted (lamby)
  • Type of work changed from Wait to Code

#16 Updated by intrigeri 20 days ago

  • Target version changed from Tails_3.14 to Tails_4.0

#17 Updated by intrigeri 20 days ago

  • Assignee set to intrigeri

#18 Updated by intrigeri 20 days ago

  • QA Check set to Ready for QA

#19 Updated by intrigeri 20 days ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

#20 Updated by intrigeri 19 days ago

  • Related to Bug #16637: squashfs-tools from Buster (1:4.3-12) is much slower than 1:4.3-8.0tails1 added

Also available in: Atom PDF