Project

General

Profile

Bug #16419

devel branch FTBFS because time-based snapshots of the "debian" archive are not updated since Jan 28

Added by intrigeri 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
02/05/2019
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

Since Jan 28:

File "pool/main/r/ruby-asset-sync/ruby-asset-sync_2.4.0.orig.tar.gz" is already registered with different checksums!
md5 expected: 1f16c4b816101b307a0b296e284d4c07, got: db15a29cac871a73f593db4643aa9027
sha256 expected: 7742f7ed2f8a4adddaa65bff0b844dd08ba73c8aafa78a0138a92863e4b79b4c, got: 7ecffe8a42d1304255385a76d80db33142dc75175b14fe313dd65ca2c1c6d5f8
size expected: 33517, got: 32735
"/usr/bin/reprepro" unexpectedly returned exit value 254 at /usr/local/bin/tails-update-time-based-apt-snapshots line 40.

Related issues

Blocks Tails - Feature #13242: Core work: Sysadmin (Maintain our already existing services) Confirmed 06/29/2017
Blocks Tails - Bug #16004: Make our automated test suite take into account USB image updates wrt. supported installation & update methods In Progress 09/28/2018
Blocks Tails - Bug #16002: Adjust our test suite for USB images Rejected 09/28/2018

History

#1 Updated by intrigeri 5 months ago

  • Blocks Feature #13242: Core work: Sysadmin (Maintain our already existing services) added

#2 Updated by intrigeri 5 months ago

  • Priority changed from Elevated to High

This problem breaks reproducibility testing of the devel branch since devel stopped FTBFS'ing on Feb 2 (that test runs 8 days in the future and the latest snapshot expires on Thu, 07 Feb 2019 11:05:04 UTC), as shown by daily failure notifications on the -rm@ list. And then devel will start FTBFS'ing in ~26 hours => bumping priority.

#3 Updated by intrigeri 5 months ago

  • Subject changed from Time-based snapshots of the "debian" archive are not updated to devel branch FTBFS because time-based snapshots of the "debian" archive are not updated since Jan 28

As expected, a first failing build: https://jenkins.tails.boum.org/view/RM/job/build_Tails_ISO_devel/3378/console

Can you handle this or do you need help?

#4 Updated by intrigeri 5 months ago

  • Blocks Bug #16004: Make our automated test suite take into account USB image updates wrt. supported installation & update methods added

#5 Updated by intrigeri 5 months ago

  • Blocks Bug #16002: Adjust our test suite for USB images added

#6 Updated by intrigeri 5 months ago

  • Assignee changed from bertagaz to intrigeri

Most branches FTBFS on Jenkins due to this issue so I'll handle it.

#7 Updated by intrigeri 5 months ago

Here's what I did:

  1. Check that we don't care about this package: https://tracker.debian.org/pkg/ruby-asset-sync says it's not been in testing nor sid since Dec 28. We don't use this file when building a Tails image, which is all that matters for time-based snapshots.
  2. Delete the offending file from disk.
  3. Remove reprepro's references about that file:
    1. To find them: reprepro dumpreferences | grep --fixed-strings 'pool/main/r/ruby-asset-sync/ruby-asset-sync_2.4.0.orig.tar.gz'
    2. To delete one of them e.g. reprepro _removereference s=sid=2018100901 pool/main/r/ruby-asset-sync/ruby-asset-sync_2.4.0.orig.tar.gz

Then I've triggered a new snapshot manually, using 2019020801 serial which failed today already so there's no conflict (and the who thing uses lock files so no chance a concurrent run conflicts).

I'll report back once this sync is complete and I've confirmed devel builds again.

FTR, the reprepro doc is pretty good and I doubt I could explain things better myself than it does. This being said, whenever needed, I'm happy to help, point in the right direction, review proposed actions, so that more of us feel at ease maintaining this service as part of their sysadmin maintenance duties :)

#8 Updated by intrigeri 5 months ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100

https://jenkins.tails.boum.org/job/build_Tails_ISO_devel/3380/console has passed the point when it was failing due to this bug previously.

Also available in: Atom PDF