Project

General

Profile

Bug #16414

onionshare-gui does not start in VirtualBox (with VBoxVGA and 3D acceration enabled)

Added by scootergrisen 9 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
01/31/2019
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
OnionShare

Description

Name of the affected software
-----------------------------
onionshare-gui

Exact steps to reproduce the error
----------------------------------
Start terminal
Type onionshare-gui + ENTER

Actual result and description of the error
------------------------------------------
Traceback (most recent call last):
File "/usr/bin/onionshare-gui", line 21, in <module>
import onionshare_gui
File "/usr/lib/python3/dist-packages/onionshare_gui/__init__.py", line 20, in <module>
from .onionshare_gui import *
File "/usr/lib/python3/dist-packages/onionshare_gui/onionshare_gui.py", line 22, in <module>
from PyQt5 import QtCore, QtWidgets, QtGui
ImportError: libGL.so.1: failed to map segment from shared object

Desired result
--------------
Show OnionShare window.

Works with VBoxSVGA and VMSVGA when 3D acceration is enabled but for some reason not VBoxVGA.

Se also https://github.com/micahflee/onionshare/issues/891

Tested with tails-amd64-3.12.iso in VirtualBox 6.0.


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision 242f0e43 (diff)
Added by intrigeri 7 months ago

Refresh patch (refs: #16414)

apparmor 2.13.2-10 updated abstractions/base in a way that conflicts
with the tweaks we do there to support AppArmor aliases.

History

#1 Updated by mercedes508 9 months ago

  • Assignee set to scootergrisen

Why don't you just start onionshare from the application menu?

#2 Updated by scootergrisen 9 months ago

OnionShare in the application menu runs onionshare-gui.

The .desktop file says:

Exec=/usr/bin/onionshare-gui

If i select OnionShare in the application menu i see this with "sudo dmesg":

[ 879.075447] audit: type=1400 audit(1549231684.431:39): apparmor="DENIED" operation="file_mmap" profile="/usr/bin/onionshare-gui" name="/usr/lib/VBoxOGL.so" pid=11415 comm="onionshare-gui" requested_mask="m" denied_mask="m" fsuid=1000 ouid=0

#3 Updated by u 8 months ago

I won't have time to look into this soon unfortunately. But putting it on my radar anyway.

#4 Updated by scootergrisen 8 months ago

If you got some ideas on what i could try to get closed to what the problem might be i could try that in the mean time.

#5 Updated by intrigeri 8 months ago

  • Subject changed from onionshare-gui dont want to start in VirtualBox (with VBoxVGA and 3D acceration enabled) to onionshare-gui does not start in VirtualBox (with VBoxVGA and 3D acceration enabled)
  • Status changed from New to Confirmed
  • Assignee changed from scootergrisen to intrigeri
  • Target version set to Tails_3.13

This seems to be a bug in the AppArmor profile we ship. It seems it's been upstreamed but is not shipped in the Debian package yet (see #11929#note-15) so let's fix it on our side for now. I'll check if the problem is in an abstraction.

#6 Updated by intrigeri 8 months ago

  • Related to Feature #11929: Upstream AppArmor profiles for Onionshare added

#7 Updated by intrigeri 8 months ago

#8 Updated by intrigeri 8 months ago

Reproduced.

#9 Updated by intrigeri 8 months ago

At first glance, it looks like /etc/apparmor.d/abstractions/base expects all shared libraries to be called lib*.so, while this one is called VBoxOGL.so.

#10 Updated by intrigeri 8 months ago

  • Related to deleted (Feature #11929: Upstream AppArmor profiles for Onionshare)

#11 Updated by intrigeri 8 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

Asked on https://gitlab.com/apparmor/apparmor/merge_requests/345 why the policy is the way it is.

#12 Updated by intrigeri 7 months ago

  • Target version changed from Tails_3.13 to Tails_3.14

Pinged on the upstream discussion. I don't expect we'll reach a conclusion that we can implement in time for 3.13.

#13 Updated by intrigeri 7 months ago

#14 Updated by intrigeri 7 months ago

#15 Updated by intrigeri 7 months ago

  • % Done changed from 10 to 20

It seems that consensus was reached upstream. I'd rather resolve the conflicts of the proposed fix with our config/chroot_local-patches/apparmor-aliases.diff only once, so my plan is:

  1. get this merged upstream
  2. apply the fix in Debian, batch this with other bugfixes and get this unblocked for migration to Debian testing; I'll try to do this at the BSP at the end of March
  3. once it's in Debian testing, feature/buster will FTBFS and I'll have to resolve the merge conflict

#16 Updated by CyrilBrulebois 7 months ago

I think I now understand what the current (in feature/buster) patch does, but I'm not sure how to forward these changes with the new apparmor code (as of 2.13.2-10).

I'd be happy to get from you an updated hunk for the /etc/apparmor.d/abstractions/base file…

#17 Updated by intrigeri 7 months ago

CyrilBrulebois wrote:

I'd be happy to get from you an updated hunk for the /etc/apparmor.d/abstractions/base file…

I've done one of the possible conflict resolutions and will push once I confirm it at least fixes the FTBFS. Then our test suite should tell us if my conflict resolution breaks stuff.

#18 Updated by intrigeri 7 months ago

  • Target version changed from Tails_3.14 to Tails_4.0

#19 Updated by intrigeri 7 months ago

  • Assignee changed from intrigeri to CyrilBrulebois
  • QA Check set to Ready for QA

@CyrilBrulebois, @hefee I've pushed a candidate conflict resolution that allows the build to reach the next failure (#16604).

#20 Updated by intrigeri 7 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (CyrilBrulebois)
  • % Done changed from 20 to 100
  • QA Check changed from Ready for QA to Pass

What this ticket was about has been fixed on feature/buster. Please file a new, dedicated ticket if I got the merge conflict resolution wrong :)

Also available in: Atom PDF