Project

General

Profile

Bug #16412

Missing signature file

Added by mercedes508 about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Installation
Target version:
Start date:
01/31/2019
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Installation Assistant

Associated revisions

Revision c3171054 (diff)
Added by sajolida about 1 year ago

Display missing bits on download-only pages (Closes: #16412)

History

#1 Updated by Anonymous about 1 year ago

I'm trying to debug this, but if I fail, I let you take over.
I'm seeing that files in wiki/src/install/inc/steps/download.inline.html are called from wiki/src/inc/stable_amd64_img_sig_url.html but they don't seem to be included. So these files do exist but are not included via ikiwiki. AND they are called from wiki/src/install which has it's own "inc" folder, but we are looking at the ../inc folder. I fear it might be due to some missing or faulty rewrite directive.

#3 Updated by Anonymous about 1 year ago

I don't think I can do this, and I suspect it has something to do with rewrite directives of ikiwiki.

#4 Updated by sajolida about 1 year ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

#5 Updated by Anonymous about 1 year ago

That was a CSS issue? I wonder if this is a sustainable thing or if we might end up having more of such problems when working on these pages.

#6 Updated by sajolida about 1 year ago

It's how all our installation pages have been working since we wrote them in 2015. See "Conditional CSS content", it's hackish and painful to maintain but so it hasn't worked so bad in its 3 years of existence and we simplified them a lot with USB images.

Now, I'd be super interested if you can think of a better solution; I personally didn't find any.

#7 Updated by sajolida about 1 year ago

Oops, I forgot the URL: see "Conditional CSS content" in https://tails.boum.org/contribute/design/installation_assistant/.

#8 Updated by Anonymous about 1 year ago

sajolida wrote:

It's how all our installation pages have been working since we wrote them in 2015. See "Conditional CSS content", it's hackish and painful to maintain but so it hasn't worked so bad in its 3 years of existence and we simplified them a lot with USB images.

Right. I think this is useful on some parts. But I find it complicated that a forgotten class on a link makes the link invisible. It should be the contrary: this link should be visible unless I add a class to it.

Now, I'd be super interested if you can think of a better solution; I personally didn't find any.

What I generally do is:

- add a class to the body or any other parent element, like your windows or linux class. You do that only once.

- Then always use the same classes within the document for links that might be visible or invisible so that you can define the CSS like that:

.windows .somelink { display: none; }
.linux .somelink {display: inline-block; }

I'm not saying this is a must, but it would avoid such mistakes IMO.

Also available in: Atom PDF