Project

General

Profile

Feature #16408

Document how to run from a virtual USB storage in virt-manager from a USB image

Added by u 10 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
01/29/2019
Due date:
% Done:

100%

Feature Branch:
doc/16408-usb-image-virt-manager
Type of work:
Website
Blueprint:
Starter:
Affected tool:

Description

Is there a plan to update the documentation of running Tails from a virtual USB storage in virt-manager (https://tails.boum.org/doc/advanced_topics/virtualization/virt-manager/index.en.html#index5h1)? The USB image can be used for this instead of using Tails Installer. The image must be increased to be at least 7200 MiB, I always do this with this command:

dd if=/dev/zero of=PATH_TO_TAILS.img conv=notrunc oflag=append bs=1000M count=6

FWIW one can get a simpler command line by using truncate.


Related issues

Related to Tails - Bug #16006: USB image: adjust documentation Resolved 04/14/2016

Associated revisions

Revision 70755d6f (diff)
Added by segfault 9 months ago

Document using the USB image in virt-manager (refs: #16408)

Revision eda77b07 (diff)
Added by segfault 8 months ago

Don't use OS type "Generic default" in virt-manager (refs: #16408)

On my system (Debian Sid), new machines I create with OS type "Generic
default" miss the spice channel required to share the clipboard between
host and guest. When I create the machine as "Debian Stretch", this
channel is automatically added.

Revision 013f504e
Added by intrigeri 7 months ago

Merge remote-tracking branch 'origin/doc/16408-usb-image-virt-manager'

Closes: #16408

History

#1 Updated by u 10 months ago

  • Target version set to Tails_3.13

Could you provide a doc branch with this information please? Then reassign to intrigeri for review? Thanks!

#2 Updated by u 10 months ago

  • Related to Bug #16006: USB image: adjust documentation added

#4 Updated by sajolida 10 months ago

  • Tracker changed from Bug to Feature
  • Subject changed from Update doc for running Tails from a virtual USB storage in virt-manager to Document how to run from a virtual USB storage in virt-manager from a USB image

Good catch! I didn't think about updating this section but it would be great.

Note that the current section still works and that this work was not initially budgeted for Sponsor_I. So I think we should drop the "Deliverable for" and make this a Low priority (and Starter) task.

Would the first step be to update the command line to use truncate as proposed by intrigeri on #16006#note-14.

I'm fine with reviewing a branch after somebody else writes a draft.

#5 Updated by u 10 months ago

maybe segfault can provide the draft because he has certainly done this in the past for testing :)

#6 Updated by segfault 9 months ago

  • Status changed from Confirmed to In Progress

#7 Updated by segfault 9 months ago

  • Assignee changed from segfault to sajolida
  • QA Check set to Ready for QA
  • Feature Branch set to doc/16408-usb-image-virt-manager
  • Type of work changed from Contributors documentation to Website

I drafted something

#8 Updated by u 9 months ago

Thank you @segfault!

#9 Updated by sajolida 8 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

I improve some styling in 160e27ca60 and 177d408d1f and merged it.

Thanks a lot @segfault, I would never have found the time to update this myself...

#10 Updated by segfault 8 months ago

  • Status changed from Resolved to In Progress
  • Assignee set to sajolida
  • Target version changed from Tails_3.13 to Tails_3.14
  • QA Check set to Ready for QA

In my draft I wrote that the OS type of the VM could be set to either "Debian Stretch" or "Generic default". But I just noticed that on my system (Debian Sid), new machines I create with OS type "Generic default" miss the spice channel required to share the clipboard between host and guest. When I create the machine as "Debian Stretch", this channel is automatically added. So I pushed a commit which removes the "Generic default" part.

#11 Updated by intrigeri 7 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

#12 Updated by intrigeri 7 months ago

  • Assignee deleted (sajolida)
  • QA Check changed from Ready for QA to Pass

Thanks, merged.

#13 Updated by intrigeri 6 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

#14 Updated by anonym 6 months ago

  • Target version changed from Tails_3.13.2 to Tails_3.14

#15 Updated by intrigeri 6 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

Also available in: Atom PDF