Project

General

Profile

Bug #16370

isobuilders can't start Vagrant VMs => all ISO builds fail

Added by intrigeri 6 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
01/18/2019
Due date:
% Done:

0%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

See e.g. /var/log/libvirt/qemu/tails-builder-amd64-stretch-20190114-e426707444_default.log on isobuilder1.lizard.

I've verified that /sys/module/kvm_intel/parameters/nested says Y on lizard.

History

#1 Updated by groente 6 months ago

  • Status changed from Confirmed to In Progress
  • Priority changed from High to Elevated

it's definately kernel-related.

rolled back to an older one and nested kvm works again.

#2 Updated by anonym 6 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#3 Updated by intrigeri 5 months ago

In /var/log/libvirt/qemu/tails-builder-amd64-stretch-20190125-e43d76a8c7_default.log on isobuilder1 I see "KVM: entry failed, hardware error 0x7"; this looks a bit like https://lkml.org/lkml/2019/1/22/682 and https://patchwork.kernel.org/patch/10763351/. Older instances of this error seem to be fixable by using a less extreme vcpu configuration; I've tried CPU mode host-model (for the Vagrant box) and it did not help.

#4 Updated by CyrilBrulebois 4 months ago

  • Target version changed from Tails_3.13 to Tails_3.14

#5 Updated by intrigeri 3 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (groente)

It seems that @bertagaz rebooted on 4.19.0-0.bpo.4-amd64 i.e. 4.19.28-2~bpo9+1 and Jenkins builds started since the reboot managed to start Vagrant. Calling this done then! :)

#6 Updated by bertagaz 3 months ago

intrigeri wrote:

It seems that @bertagaz rebooted on 4.19.0-0.bpo.4-amd64 i.e. 4.19.28-2~bpo9+1 and Jenkins builds started since the reboot managed to start Vagrant. Calling this done then! :)

Yes, I was willing to wait a bit before reporting on this ticket.

#7 Updated by intrigeri 2 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

#8 Updated by anonym 2 months ago

  • Target version changed from Tails_3.13.2 to Tails_3.14

#9 Updated by intrigeri 2 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

Also available in: Atom PDF