Project

General

Profile

Feature #16368

Test all the Wi-Fi adapters that we have with Tails 4.0

Added by sajolida 11 months ago. Updated 16 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Hardware support
Target version:
Start date:
01/16/2019
Due date:
% Done:

0%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
Affected tool:

Description

History

#1 Updated by intrigeri 6 months ago

I assume doing this for major Tails N.0 releases is merely a way to create a schedule for this. FYI, in practice, the software+firmware components relevant to Wi-Fi adapters support are rarely updated in these releases, but often at other times.

#2 Updated by sajolida 6 months ago

Pretty much :) I knew that we were doing kernel and firmware updates
inbetween Debian versions but I didn't know what Debian version rarely
also include kernel and firmware updates.

#3 Updated by intrigeri 6 months ago

I didn't know what Debian version rarely also include kernel and firmware updates.

To clarify, major Debian releases do include kernel and firmware updates, but:

  • In general, we've already shipped these updates earlier. E.g. Tails 3.x has had since a while the kernel and firmware that will be shipped with Buster.
  • In the last ~6 months before a major Debian release, no big changes are made (freeze) which increases the chances that the new Debian release won't bring newer stuff than what we ship already.

#4 Updated by sajolida 2 months ago

  • Target version changed from Tails_4.0 to Tails_4.1

#5 Updated by sajolida 16 days ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)

Yes, targetting 4.0 was somehow arbitrary. Next time I'll try to target a kernel and firmware update more specifically.

Done for 4.0. 2 of them had some changes:

  • TP-Link Archer T2U started working but I have a pretty old version.
  • TP-Link TL-WN722N now loads a firmware but fails on MAC spoofing.

Also available in: Atom PDF