Project

General

Profile

Feature #16350

Add feedback when opening Onion Circuits

Added by sajolida 6 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
01/12/2019
Due date:
% Done:

100%

Feature Branch:
feature/16350-onioncircuits-opening-feedback, onioncircuits.git:feature/16350-opening-feedback
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Onion Circuits

Description

See #15738.


Related issues

Related to Tails - Bug #16333: Add feedback when opening WhisperBack Resolved 01/09/2019
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed 03/22/2019

Associated revisions

Revision 4a751270 (diff)
Added by segfault 3 months ago

Enable the feature-16350-onioncircuits-opening-feedback APT overlay (refs: #16350).

Revision c48e12b4
Added by segfault 3 months ago

Merge branch 'feature/16350-onioncircuits-opening-feedback' into stable (Fix-committed: #16350)

History

#1 Updated by sajolida 6 months ago

  • Assignee changed from sajolida to segfault
  • QA Check set to Ready for QA
  • Feature Branch set to onioncircuits.git:feature/16350-opening-feedback

Here is a branch.

#2 Updated by segfault 6 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

I fixed a typo, beside that the code review passes

#3 Updated by intrigeri 4 months ago

segfault wrote:

I fixed a typo, beside that the code review passes

@segfault, is there anything else you plan to do here? It looks like this fix has been waiting for a while on your plate after that successful review.

#4 Updated by intrigeri 4 months ago

  • Status changed from Confirmed to In Progress

#5 Updated by intrigeri 4 months ago

#6 Updated by CyrilBrulebois 4 months ago

  • Target version changed from Tails_3.13 to Tails_3.14

#7 Updated by segfault 3 months ago

  • Related to Bug #16333: Add feedback when opening WhisperBack added

#8 Updated by segfault 3 months ago

I fixed the duplicate StartupNotify=true entry, released a new version, built a new Debian package and tested it. Now in order to use this new Debian packgage, we would have to install onioncircuits from our own repo, which we currently don't do. Should I prepare a branch for that?

#9 Updated by intrigeri 3 months ago

Now in order to use this new Debian packgage, we would have to install onioncircuits from our own repo, which we currently don't do. Should I prepare a branch for that?

Yes. In that branch you can run ./bin/add-APT-overlay then upload your package to the corresponding APT (overlay) suite.

#10 Updated by segfault 3 months ago

intrigeri wrote:

Now in order to use this new Debian packgage, we would have to install onioncircuits from our own repo, which we currently don't do. Should I prepare a branch for that?

Yes. In that branch you can run ./bin/add-APT-overlay then upload your package to the corresponding APT (overlay) suite.

Oh that I already did, in order to test the package. What I meant is a branch to merge into devel/stable in order to have the new Debian package in the next Tails release. For that we would have to add a pin to origin deb.tails.boum.org in config/chroot_apt/preferences, right?

#11 Updated by intrigeri 3 months ago

  • Feature Branch changed from onioncircuits.git:feature/16350-opening-feedback to feature/16350-onioncircuits-opening-feedback, onioncircuits.git:feature/16350-opening-feedback

#12 Updated by intrigeri 3 months ago

Yes. In that branch you can run ./bin/add-APT-overlay then upload your package to the corresponding APT (overlay) suite.

Oh that I already did, in order to test the package.

Hmmm, something went wrong. This tells me the APT suite is empty:

ssh reprepro@incoming.deb.tails.boum.org reprepro list feature-16350-onioncircuits-opening-feedback

And I see no version newer than 0.3-0tails2 when I run:

ssh reprepro@incoming.deb.tails.boum.org reprepro ls onioncircuits

This may invalidate the tests you did already on an image built from this branch.

On the server, /var/log/incoming-tails.log says No distribution found for 'onioncircuits_0.6-0.0tails1_amd64.changes'! and incoming/onioncircuits_0.6-0.0tails1_amd64.changes has Distribution: feature-16350-onioncircuits-opening-feedback, which is correct. So I think you uploaded before the cronjob created that APT suite. I've touch'ed the .changes file to force inotify+reprepro to process it again and now your package been imported :)

Then I've triggered a new build on https://jenkins.tails.boum.org/view/Tails_ISO/job/build_Tails_ISO_feature-16350-onioncircuits-opening-feedback/9/

What I meant is a branch to merge into devel/stable in order to have the new Debian package in the next Tails release. For that we would have to add a pin to origin deb.tails.boum.org in config/chroot_apt/preferences, right?

I believe our existing catch-all APT pinning is sufficient, as long as the package's version is greater than the one from Debian. The .packages file for the aforementioned Jenkins build will tell.

#13 Updated by segfault 3 months ago

intrigeri wrote:

Yes. In that branch you can run ./bin/add-APT-overlay then upload your package to the corresponding APT (overlay) suite.

Oh that I already did, in order to test the package.

Hmmm, something went wrong. This tells me the APT suite is empty:

[...]

And I see no version newer than 0.3-0tails2 when I run:

[...]

This may invalidate the tests you did already on an image built from this branch.

It might be that the image I tested this with did not have the correct onioncircuits version installed, because I just noticed that I also get visual feedback when I open the old onioncircuits version (cursor spins, icon and name appear in top bar). This seems to be because the line StartupNotify=true was already present in the .desktop file, and a StartupWMClass line was also already there. Now I wonder how all the work it took to build and use this package compares to the benefit we get from it (fixing a typo in the StartupWMClass).

#14 Updated by segfault 3 months ago

  • QA Check changed from Ready for QA to Pass

I now also tested this with the correct package version installed via the APT overlay and it still works.

#15 Updated by segfault 3 months ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 0 to 100

#16 Updated by intrigeri 3 months ago

@segfault, I've thus merged stable into devel and in turn, devel into feature/buster.

Thanks!

#17 Updated by intrigeri 2 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

#18 Updated by anonym 2 months ago

  • Status changed from Fix committed to Resolved

#19 Updated by anonym 2 months ago

  • Target version changed from Tails_3.13.2 to Tails_3.14

#20 Updated by intrigeri 2 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

Also available in: Atom PDF