Project

General

Profile

Bug #16338

Tor Launcher is not localized

Added by anonym 8 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Internationalization
Target version:
Start date:
01/10/2019
Due date:
% Done:

100%

Feature Branch:
bugfix/16338-tor-launcher-localization+force-all-tests
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Tor Launcher

Description

Regression introduced when migrating to Tor Browser 8.x in Tails 3.9~rc1 (Tails 3.8 with the last Tor Browser 7.5.x release is fine).


Related issues

Related to Tails - Bug #15388: Network Setting Wizard doesn't work in Swedish Resolved 03/08/2018
Duplicated by Tails - Feature #16444: tor-launcher is missing translations Duplicate 02/08/2019
Blocks Tails - Feature #15507: Core work 2019Q1: Foundations Team Resolved 04/08/2018

Associated revisions

Revision 4a32a553 (diff)
Added by anonym 8 months ago

Fix localization for Tor Launcher.

Regression introduced when migrating to Tor Browser 8.x in Tails
3.9~rc1.

Will-fix: #16338

Revision 4766ca06 (diff)
Added by anonym 7 months ago

Tor Launcher: add langpacks to enable localization (Will-fix: #16338).

Regression introduced when migrating to Tor Browser 8.x in Tails
3.9~rc1 (Tails 3.8 with the last Tor Browser 7.5.x release is fine).

Revision 7dc8f638 (diff)
Added by anonym 7 months ago

Tor Launcher: add langpacks to enable localization (Will-fix: #16338).

Regression introduced when migrating to Tor Browser 8.x in Tails
3.9~rc1 (Tails 3.8 with the last Tor Browser 7.5.x release is fine).

Revision d7fcf03a (diff)
Added by intrigeri 6 months ago

Update comment to match current code (refs: #16338)

7dc8f638eaf00201a441d5a74337174c1d3912b7 introduced usage
of $TBB_EXT.

Revision c3e4e2ca
Added by intrigeri 6 months ago

Merge branch 'bugfix/16338-tor-launcher-localization+force-all-tests' into stable (Fix-committed: #16338)

History

#1 Updated by anonym 8 months ago

#2 Updated by anonym 8 months ago

Here's the fix:

--- a/config/chroot_local-includes/usr/local/bin/tor-launcher
+++ b/config/chroot_local-includes/usr/local/bin/tor-launcher
@@ -18,8 +18,11 @@ fi

 PROFILE="${HOME}/.tor-launcher/profile.default" 
 if [ ! -d "${PROFILE}" ]; then
-  mkdir -p "${PROFILE}" 
-  configure_best_tor_launcher_locale "${PROFILE}" 
+    mkdir -p "${PROFILE}/extensions" 
+    for ext in "${TBB_EXT}"/langpack-*.xpi; do
+        ln -s "${ext}" "${PROFILE}/extensions" 
+    done
+    configure_best_tor_launcher_locale "${PROFILE}" 
 fi

 exec_unconfined_firefox \

However, since we probably have to rework everything Tor Launcher-related (#15709) we might want to hold off on this, and possibly just reject it.

#3 Updated by intrigeri 8 months ago

However, since we probably have to rework everything Tor Launcher-related (#15709) we might want to hold off on this, and possibly just reject it.

My take on this is: batch this with the branch + build + test + QA for the Tor Browser upgrade in 3.12, so it'll come almost for free. And if that's not possible or does not work, reject.

#4 Updated by anonym 8 months ago

  • Status changed from Confirmed to In Progress

#5 Updated by anonym 8 months ago

Thanks, intri, that's a great idea!

#6 Updated by anonym 8 months ago

Wow, I was very confused and pushed this to the feature/16337-tor-browser-8.5+force-all-test. Dropped from that branch + force-pushed, FWIW.

#7 Updated by anonym 8 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

I failed (well, forgot) to do this. :/

#8 Updated by intrigeri 7 months ago

  • Duplicated by Feature #16444: tor-launcher is missing translations added

#9 Updated by anonym 7 months ago

  • % Done changed from 0 to 40
  • QA Check set to Dev Needed
  • Feature Branch set to bugfix/16338-tor-launcher-localization

#10 Updated by anonym 7 months ago

  • Category set to Internationalization
  • Assignee deleted (anonym)
  • % Done changed from 40 to 50
  • QA Check changed from Dev Needed to Ready for QA
  • Affected tool changed from Browser to Tor Launcher

#11 Updated by intrigeri 7 months ago

  • Assignee set to anonym
  • QA Check changed from Ready for QA to Info Needed

Most (or even all?) tests that use Tor Launcher are fragile so please +force-all-tests.

#12 Updated by anonym 7 months ago

  • QA Check changed from Info Needed to Ready for QA
  • Feature Branch changed from bugfix/16338-tor-launcher-localization to bugfix/16338-tor-launcher-localization+force-all-tests

#13 Updated by intrigeri 7 months ago

  • Related to Bug #15388: Network Setting Wizard doesn't work in Swedish added

#14 Updated by intrigeri 7 months ago

Can you please check that we don't reintroduce #15388 while fixing this bug?

#15 Updated by intrigeri 6 months ago

  • Assignee changed from anonym to intrigeri

I'll at least check the status.

#16 Updated by intrigeri 6 months ago

Code review passes modulo a comment needed updating (done: d7fcf03aba7fdaf9d783fa30a7f870a0d43d3678). No related test failures on Jenkins but it only tests Tor Launcher in English (otherwise we would have spotted this very bug earlier).

Successfully tested manually in English, Spanish, French, Farsi, Swedish, and Chinese (that all have at least some degree of localization).

intrigeri wrote:

Can you please check that we don't reintroduce #15388 while fixing this bug?

I did that and we're good :)

⇒ Merging!

#17 Updated by intrigeri 6 months ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#18 Updated by intrigeri 6 months ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

#19 Updated by CyrilBrulebois 6 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF