Project

General

Profile

Feature #16334

Add feedback when opening VeraCrypt Mounter

Added by sajolida 7 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
01/09/2019
Due date:
% Done:

100%

Feature Branch:
feature/16334-feedback-when-opening-veracrypt
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

See #15738.

0001-Give-visual-feedback-while-starting.patch View (1.21 KB) sajolida, 01/09/2019 05:34 PM


Related issues

Related to Tails - Bug #15738: Test feedback when opening applications from the Applications menu Resolved 07/17/2018
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed 03/22/2019

Associated revisions

Revision 0088f154 (diff)
Added by segfault 7 months ago

unlock-veracrypt-volumes: Give visual feedback while starting (refs: #16334)

Revision f2cc0f1f
Added by segfault 7 months ago

Merge branch 'feature/16334-feedback-when-opening-veracrypt' into devel (Fix-committed: #16334)

Revision 7235487c
Added by intrigeri 6 months ago

Merge remote-tracking branch 'origin/feature/16334-feedback-when-opening-veracrypt' into stable (Fix-committed: #16334)

History

#1 Updated by sajolida 7 months ago

Here is a patch.

#2 Updated by intrigeri 7 months ago

  • Assignee set to segfault

Hi segfault! Do you want to take this one? Optimistically assigning #16333 to you as well since it is similar (happy to do the release + package update work myself once the code review & testing passes on your side).

#3 Updated by intrigeri 7 months ago

  • Related to Bug #15738: Test feedback when opening applications from the Applications menu added

#4 Updated by segfault 7 months ago

  • Assignee changed from segfault to sajolida
  • QA Check changed from Ready for QA to Dev Needed

intrigeri wrote:

Hi segfault! Do you want to take this one?

Yes.

Optimistically assigning #16333 to you as well since it is similar

OK.

Here is a patch.

It doesn't seem to work or I don't understand what it's supposed to do. I tested it by adding the two lines to the desktop launcher in Tails (which is called unlock-veracrypt-volumes and not veracrypt-mounter) and then starting the app. I expected the mouse cursor to spin until the window is shown, but the cursor didn't change. I see a spinner in the top bar but that is also present without the two lines. I made sure that when I start the app it does indeed use the modified desktop launcher (tested by changing the Exec line).

#5 Updated by sajolida 7 months ago

I don't understand what it's supposed to do.

Yes, It's supposed to change the mouse cursor into a spinner right after
choosing to start the app. Since VeraCrypt Mounter opens super fast,
it's only visible for less than a second on my machine (but I guess it
could take longer in worse conditions).

I made sure that when I start the app it does indeed use the modified desktop launcher (tested by changing the Exec line).

Did you also restart GNOME Shell? I need to do this for my changes to be
applied on Tails:

Alt + F2 + typing "r" or "gnome-shell --replace"

#6 Updated by sajolida 7 months ago

  • Assignee changed from sajolida to segfault
  • QA Check changed from Dev Needed to Ready for QA

#7 Updated by segfault 7 months ago

  • Feature Branch set to feature/16334-feedback-when-opening-veracrypt

Did you also restart GNOME Shell? I need to do this for my changes to be
applied on Tails:

Alt + F2 + typing "r" or "gnome-shell --replace"

This worked, thanks for the hint.

I applied the patch and am now building the branch to test it. Maybe this can still make it into 3.12.

#8 Updated by segfault 7 months ago

I applied the patch

I replaced veracrypt-mounter with unlock-veracrypt-volumes in the patch.

#9 Updated by sajolida 7 months ago

I replaced veracrypt-mounter with unlock-veracrypt-volumes in the patch.

Sure :)

#10 Updated by segfault 7 months ago

  • Status changed from Confirmed to In Progress

#11 Updated by segfault 7 months ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 0 to 100

#12 Updated by segfault 7 months ago

  • Target version changed from Tails_3.12 to Tails_3.13
  • % Done changed from 100 to 0
  • QA Check changed from Ready for QA to Pass

Built the branch and tested it. Merged into devel.

#13 Updated by intrigeri 6 months ago

  • Status changed from Fix committed to In Progress
  • Assignee changed from segfault to intrigeri
  • % Done changed from 0 to 90

3.13 won't be built from devel and there's a chance we have no major release for a long while, so I'll consider cherry-picking this into stable later this week.

#14 Updated by intrigeri 6 months ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 90 to 100

#15 Updated by intrigeri 6 months ago

  • Assignee deleted (intrigeri)

Merged into stable as well, so this gets released sooner rather than later. Thanks!

#16 Updated by CyrilBrulebois 5 months ago

  • Status changed from Fix committed to Resolved

#17 Updated by intrigeri 4 months ago

Also available in: Atom PDF