Project

General

Profile

Bug #16333

Add feedback when opening WhisperBack

Added by sajolida 8 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
01/09/2019
Due date:
% Done:

100%

Feature Branch:
whisperback:feature/16333-opening-feedback
Type of work:
Code
Blueprint:
Starter:
Affected tool:
WhisperBack

Description

See #15738.


Related issues

Related to Tails - Bug #15738: Test feedback when opening applications from the Applications menu Resolved 07/17/2018
Related to Tails - Feature #16350: Add feedback when opening Onion Circuits Resolved 01/12/2019
Blocks Tails - Feature #15507: Core work 2019Q1: Foundations Team Resolved 04/08/2018

History

#1 Updated by sajolida 8 months ago

  • Affected tool set to WhisperBack

#2 Updated by sajolida 8 months ago

  • QA Check set to Ready for QA
  • Feature Branch set to feature/16333-opening-feedback

Here is a branch.

#3 Updated by sajolida 8 months ago

  • Assignee deleted (sajolida)
  • Target version set to Tails_3.12

#4 Updated by intrigeri 8 months ago

  • Related to Bug #15738: Test feedback when opening applications from the Applications menu added

#5 Updated by intrigeri 8 months ago

  • Status changed from Confirmed to In Progress
  • Assignee set to segfault

#6 Updated by segfault 8 months ago

  • Feature Branch changed from feature/16333-opening-feedback to whisperback:feature/16333-opening-feedback

Code review passes

#7 Updated by segfault 8 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#8 Updated by intrigeri 6 months ago

segfault wrote:

Code review passes

@segfault, is there anything else you plan to do here? It looks like this fix has been waiting for a while on your plate since that successful review.

#9 Updated by intrigeri 6 months ago

#10 Updated by segfault 6 months ago

  • Assignee changed from segfault to intrigeri
  • QA Check changed from Ready for QA to Info Needed

I'm not sure about the procedure here. Should I build and test the Debian package with this change before merging? Who is responsible for releasing a new version of the Debian package containing this change? Same applies for Onion Circuits (#16350).

#11 Updated by intrigeri 6 months ago

Yo @segfault :)

I'm not sure about the procedure here. Should I build and test the Debian package with this change before merging? Who is responsible for releasing a new version of the Debian package containing this change?

Someone — usually the reviewer — would prepare a new upstream release, build a Debian package, upload it to an overlay APT suite, make sure the resulting tails.git branch passes CI, merge into whatever branch in tails.git this is meant to go, and finally mark the ticket as "Fix committed". Yes, it's lots of overhead (I have secret plans to build such tiny custom packages of ours as part of the Tails ISO/IMG build process so we can skip most of the overhead).

Relevant doc:

In the case at hand, hold on: I'll review the proposed fix for #16333 right away and if it's good enough for 3.13, I'll do the whole dance myself and will merge the branch for this very ticket at the same time.

In any case, I've quickly tested this while I was doing stuff on the WhisperBack front anyway, and it works ⇒ merged into WhisperBack's master branch so it'll be in the next WhisperBack release.

#12 Updated by intrigeri 6 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100
  • QA Check changed from Info Needed to Pass

Released in WhisperBack 1.7.21.

#13 Updated by intrigeri 6 months ago

#14 Updated by intrigeri 6 months ago

#15 Updated by segfault 6 months ago

intrigeri wrote:

Yo @segfault :)

I'm not sure about the procedure here. Should I build and test the Debian package with this change before merging? Who is responsible for releasing a new version of the Debian package containing this change?

Someone — usually the reviewer — would prepare a new upstream release, build a Debian package, upload it to an overlay APT suite, make sure the resulting tails.git branch passes CI, merge into whatever branch in tails.git this is meant to go, and finally mark the ticket as "Fix committed". Yes, it's lots of overhead (I have secret plans to build such tiny custom packages of ours as part of the Tails ISO/IMG build process so we can skip most of the overhead).

Relevant doc:

In the case at hand, hold on: I'll review the proposed fix for #16333 right away and if it's good enough for 3.13, I'll do the whole dance myself and will merge the branch for this very ticket at the same time.

In any case, I've quickly tested this while I was doing stuff on the WhisperBack front anyway, and it works ⇒ merged into WhisperBack's master branch so it'll be in the next WhisperBack release.

OK, thanks for taking over :)

#16 Updated by CyrilBrulebois 6 months ago

  • Status changed from Fix committed to Resolved

#17 Updated by segfault 6 months ago

  • Related to Feature #16350: Add feedback when opening Onion Circuits added

Also available in: Atom PDF