Project

General

Profile

Bug #16317

Bug #16281: Update the test suite for Buster

persistence.feature fails due to NetworkManager test

Added by CyrilBrulebois 10 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
01/07/2019
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Checking the snapshot removal (#16316) helped with persistence.feature, that seems way better. This fails though:

    And Tor is ready                                                                                              # features/step_definitions/common_steps.rb:352
    And I add a current wired DHCP NetworkManager connection called "persistent-con-current"                      # features/step_definitions/common_steps.rb:576
      Unsupported version 'current ' (RuntimeError)
      ./features/step_definitions/common_steps.rb:578:in `/^I add a ([a-z0-9.]+ |)wired DHCP NetworkManager connection called "([^"]+)"$/'
      features/persistence.feature:37:in `And I add a current wired DHCP NetworkManager connection called "persistent-con-current"'

Failing Scenarios:
cucumber features/persistence.feature:33 # Scenario: Creating and using a persistent NetworkManager connection

6 scenarios (1 failed, 5 passed)
46 steps (1 failed, 8 skipped, 37 passed)
75m27.923s

which isn't surprising given the current implementation in features/step_definitions/common_steps.rb:

Given /^I add a ([a-z0-9.]+ |)wired DHCP NetworkManager connection called "([^"]+)"$/ do |version, con_name|
  if not version.empty?
    raise "Unsupported version '#{version}'" 
  else
    $vm.execute_successfully(
      "nmcli connection add con-name #{con_name} " + \
      "type ethernet autoconnect yes ifname eth0" 
    )
  end
  try_for(10) {
    nm_con_list = $vm.execute("nmcli --terse --fields NAME connection show").stdout
    nm_con_list.split("\n").include? "#{con_name}" 
  }
end

as we have a non-empty version (i.e. current).


Related issues

Related to Tails - Bug #16316: Black screen/apparent machine crash in test suite due to snapshot mechanism? Resolved 01/07/2019

Associated revisions

Revision 33d3b358 (diff)
Added by intrigeri 8 months ago

Test suite: fix NetworkManager step (refs: #16317)

The corresponding step definition does not support "current": it supports either
a version number or nothing.

History

#1 Updated by CyrilBrulebois 10 months ago

  • Related to Bug #16316: Black screen/apparent machine crash in test suite due to snapshot mechanism? added

#2 Updated by CyrilBrulebois 10 months ago

  • Description updated (diff)

#3 Updated by intrigeri 10 months ago

  • Status changed from New to Confirmed
  • Assignee deleted (intrigeri)
  • Parent task set to #16281

#4 Updated by CyrilBrulebois 10 months ago

  • Subject changed from persistence.feature fails due on NetworkManager test to persistence.feature fails due to NetworkManager test

#5 Updated by intrigeri 8 months ago

  • Status changed from Confirmed to In Progress

#6 Updated by intrigeri 8 months ago

  • Assignee set to CyrilBrulebois
  • QA Check set to Ready for QA
  • Type of work changed from Test to Code

Pushed a tentative fix.

#7 Updated by hefee 8 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (CyrilBrulebois)
  • QA Check changed from Ready for QA to Pass

Tails persistence tests passes now on Jenkins.

Also available in: Atom PDF