Project

General

Profile

Bug #16316

Bug #16281: Update the test suite for Buster

Black screen/apparent machine crash in test suite due to snapshot mechanism?

Added by CyrilBrulebois 10 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Test suite
Target version:
Start date:
01/07/2019
Due date:
% Done:

100%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

Seen on several tests, intermittently: the screen turns black (leading to failure to find reference images, like GnomeApplicationsMenu.png).

This includes at least persistence.feature, untrusted_partitions.feature (also seen with others, but I initially thought this could be some rare glitch).

Trying to attach to the TailsToaster VM through virt-manager, and trying to send various Ctrl+Alt+Fn doesn't lead to any changes.

I'll try disabling the snapshotting mechanism to check if we can get more reliable (even if longer) runtime.


Related issues

Related to Tails - Bug #16317: persistence.feature fails due to NetworkManager test Resolved 01/07/2019

History

#1 Updated by CyrilBrulebois 10 months ago

  • Related to Bug #16317: persistence.feature fails due to NetworkManager test added

#2 Updated by intrigeri 10 months ago

  • Subject changed from Black screen/apparent machine crash due to screenshot mechanism? to Black screen/apparent machine crash in test suite due to snapshot mechanism?
  • Category set to Test suite
  • Status changed from New to Confirmed
  • Assignee deleted (intrigeri)
  • Priority changed from Normal to Elevated
  • Parent task set to #16281

Bumping priority as snapshots are a very important optimization of our test suite.

#3 Updated by CyrilBrulebois 10 months ago

Here we go: 3a95d599f6..1e51d61047 HEAD -> feature/buster

Details in 1e51d61047c966387f05f24333aeb2031589a2fa but let's maybe keep this ticket open for a little longer.

#4 Updated by intrigeri 8 months ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Let's reopen if there's anything left to do here.

Also available in: Atom PDF