Project

General

Profile

Bug #16309

Feature #10034: Translation web platform

Feature #15079: Integrate the platform with our Git and ikiwiki infrastructure

Feature #15077: Have a staging website to build planned languages, with a resilient build

Bug #15625: Create ikiwiki-staging.setup for staging website

ikiwiki tries to pull/push from git

Added by hefee 11 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
01/06/2019
Due date:
% Done:

0%

Spent time:
Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:
Translation Platform

Description

With the switch to a puppet based ikiwiki.setup file, suggestions-cronjob.sh triggers to pull and push to git. Probably this is connected to the git plugin inside ikiwiki.

Here's the output of cronjob sent by mail:

To /var/lib/weblate/repositories/vcs/tails/index
 ! [rejected]              master -> master (fetch first)
error: failed to push some refs to '/var/lib/weblate/repositories/vcs/tails/index'
hint: Updates were rejected because the remote contains work that you do
hint: not have locally. This is usually caused by another repository pushing
hint: to the same ref. You may want to first integrate the remote changes
hint: (e.g., 'git pull ...') before pushing again.
hint: See the 'Note about fast-forwards' in 'git push --help' for details.
'git push origin master' failed:  at /usr/share/perl5/IkiWiki/Plugin/git.pm line 251.
From /var/lib/weblate/repositories/vcs/tails/index
   3b09d1db34..34a85f8cd7  master     -> origin/master
internal error: recentchanges/change_6a10f6e5e68347aa1d30a5a08237b63a0aec8306._change cannot be found in /var/lib/weblate/repositories/vcs/staging/wiki/src or underlay

History

#1 Updated by groente 11 months ago

  • Assignee changed from groente to hefee
  • QA Check set to Info Needed

so, we want to diverge from production's ikiwiki.setup after all?

#2 Updated by hefee 11 months ago

  • Assignee changed from hefee to groente

groente wrote:

so, we want to diverge from production's ikiwiki.setup after all?

Sorry for that, I had forgotten, that ikiwiki is doing this.

#3 Updated by u 10 months ago

  • Description updated (diff)

#4 Updated by u 10 months ago

  • Status changed from New to Confirmed

#5 Updated by groente 10 months ago

  • Assignee changed from groente to hefee
  • QA Check changed from Info Needed to Ready for QA

rcs in the ikiwiki.setup on translate is now set to empty string, instead of git.

#6 Updated by hefee 10 months ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (hefee)
  • QA Check changed from Ready for QA to Pass

Looks fine.

Also available in: Atom PDF