Project

General

Profile

Bug #16303

tails-persistence-setup crashes due to missing electrum in feature/buster

Added by CyrilBrulebois 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Persistence
Target version:
Start date:
01/06/2019
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

electrum was disabled in feature/buster (see #16204) which leads to a crash of tails-persistence-setup after the persistence partition has been set up: when the window with the application-related choices is being prepared, the missing electrum icon in the Adwaita theme triggers a crash. Visiting e.g. the /usr/share/icons/Adwaita/scalable/apps directory and copying a random SVG file into electrum.svg prevents the crash.

Affected version: tails-persistence-setup 2.0.2-1.

This was caught by the test suite with persistence.feature (waiting happens for long minutes while the window/app is gone); and reproducing it outside the test suite, starting the application from a terminal, made it possible to figure out what was happening.

Various thoughts:

  • This (in lib/Tails/Persistence/Configuration/Setting.pm) should likely try and catch errors, maybe falling back to a “broken image” icon when the requested one isn't available?
method _build_icon () {
    Gtk3::Image->new_from_pixbuf($self->icon_theme->load_icon(
        $self->icon_name, 48, 'use-builtin'
    ));
}
  • In the meanwhile, we could patch out the electrum part of the presets through a local patch in tails.git
  • Or we could introduce a temporary electrum icon in tails.git; this would solve the crash but I'm not sure what would happen with the other widgets, so I think I'd rather patch out electrum entirely…

Related issues

Related to Tails - Bug #16204: Disabled electrum in feature/buster Confirmed 12/07/2018

Associated revisions

Revision 282920f0 (diff)
Added by CyrilBrulebois 3 months ago

Disable electrum support in tails-persistence-setup (refs: #16303).

This avoids crashes due to a missing electrum icon, until it's clearer
what happens for electrum vs. buster, and until support for it is
possibly disabled in tails-persistence-setup directly.

History

#1 Updated by intrigeri 3 months ago

  • Status changed from New to Confirmed
  • In the meanwhile, we could patch out the electrum part of the presets through a local patch in tails.git

This looks like the cheapest short-term workaround. Once we have a clearer idea of the future of Electrum in Tails (or lack thereof) we can decide what our long-term course of action should be.

#2 Updated by intrigeri 3 months ago

  • Related to Bug #16204: Disabled electrum in feature/buster added

#3 Updated by CyrilBrulebois 3 months ago

  • Status changed from Confirmed to In Progress

#4 Updated by intrigeri 3 months ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF