Project

General

Profile

Bug #16295

Various base directories/files have varying mtimes

Added by lamby 3 months ago. Updated 3 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Build system
Target version:
-
Start date:
01/05/2019
Due date:
% Done:

0%

QA Check:
Dev Needed
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Various base directories/files have varying mtimes (eg. /dev/pts, /etc)
Various base directories/files have varying mtimes (eg. /dev/pts, /etc) on feature/buster:

│ ├── unsquashfs -d '' -lls {}
│ │ @@ -176,24 +176,24 @@
[..]
│ │  crw-rw-rw- root/root             1,  9 2018-09-05 16:51 /dev/urandom
│ │  crw-rw-rw- root/root             1,  5 2018-09-05 16:51 /dev/zero
│ │ -drwxr-xr-x root/root              4825 2019-01-05 12:13 /etc
│ │ +drwxr-xr-x root/root              4825 2019-01-05 14:52 /etc
[..]
│ │ --rw-r--r-- root/root                 0 2019-01-05 12:13 /etc/hosts
│ │ +-rw-r--r-- root/root                 0 2019-01-05 14:52 /etc/hosts

Related issues

Duplicates Tails - Bug #16294: SquashFS metadata is not reproducible in buster Resolved 01/05/2019
Blocks Tails - Feature #16285: feature/buster branch is not reproducible Resolved 01/05/2019

History

#1 Updated by lamby 3 months ago

  • Blocks Feature #16285: feature/buster branch is not reproducible added

#2 Updated by lamby 3 months ago

  • QA Check set to Dev Needed

#3 Updated by intrigeri 3 months ago

Same as the other SquashFS issue: pristine squashfs-tools version is used.

#4 Updated by lamby 3 months ago

  • Status changed from New to Duplicate

Thanks, closing as a duplicate of #16294 for now

#5 Updated by lamby 3 months ago

  • Duplicates Bug #16294: SquashFS metadata is not reproducible in buster added

Also available in: Atom PDF