Project

General

Profile

Feature #16250

Feature #10034: Translation web platform

Feature #11759: Install & configure a fresh weblate on the VM

fixes for translations-server

Added by hefee 9 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
12/26/2018
Due date:
% Done:

100%

Spent time:
Feature Branch:
https://salsa.debian.org/hefee/puppet-tails/commits/hefee/dev/translation-server
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

Yet another round of fixes for the translation server.

History

#1 Updated by hefee 9 months ago

  • Feature Branch set to https://salsa.debian.org/hefee/puppet-tails/commits/hefee/dev/translation-server

#2 Updated by hefee 9 months ago

can you also check, why langs.json is not available in ~/weblate/scripts/?
I don't get it why this file is missing, it has an entry in weblate.pp:

file { "${mutable_data_dir}/scripts/langs.json":
source => 'puppet:///modules/tails/weblate/scripts/langs.json',

#3 Updated by mercedes508 9 months ago

  • Status changed from New to Confirmed

#4 Updated by groente 9 months ago

  • Assignee changed from groente to hefee
  • QA Check set to Info Needed

fixes have been merged & deployed.
i'm not sure what you mean about the langs.json file, it seems to be there?

$ ls /var/lib/weblate/scripts/langs.json 
/var/lib/weblate/scripts/langs.json

#5 Updated by hefee 9 months ago

groente wrote:

fixes have been merged & deployed.
i'm not sure what you mean about the langs.json file, it seems to be there?

$ ls /var/lib/weblate/scripts/langs.json
/var/lib/weblate/scripts/langs.json

okay another point for typos in filenames - I missed the ending "s" and checked several times against lang.json before.

I added this fix and two other fixes on my hefee/dev/translation-server branch. Please merge.

#6 Updated by groente 8 months ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (hefee)
  • % Done changed from 0 to 100
  • QA Check deleted (Info Needed)

added some extra cleanup with lang/langs mixup in puppet.

all merged & deployed now.

#7 Updated by u 7 months ago

  • Parent task changed from #10034 to #11759

Also available in: Atom PDF