Project

General

Profile

Bug #16243

release_process: maybe document filtering some elements

Added by CyrilBrulebois 10 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
Start date:
12/23/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
Contributors documentation
Blueprint:
Starter:
Affected tool:

Description

While preparing the 3.10* releases, it was decided to skip updating the config/binary_rootfs/squashfs.sort (except for the kernel ABI bump through sed → 9593161c98d48d5cff744db23e4d171819c46ebf).

While preparing the 3.11 release, I've seen a bunch of updates under /run/udev. Latest file has:

run/mount/utab
run/network/ifstate
run/systemd/generator.late/speech-dispatcher.service
run/udev/links/\x2fcdrom/b11:0
run/udev/links/\x2fdisk\x2fby-id\x2fata-QEMU_DVD-ROM_QM00001/b11:0
run/udev/links/\x2fdisk\x2fby-label\x2fTAILS\x5cx203.11\x5cx20-\x5cx2020181210/b11:0
run/udev/links/\x2fdisk\x2fby-path\x2fpci-0000:00:01.1-ata-1/b11:0
run/udev/links/\x2fdisk\x2fby-uuid\x2f2018-12-10-15-12-25-00/b11:0
run/udev/links/\x2frtc/c252:0
run/udev/tags/master-of-seat/c226:0
run/udev/tags/master-of-seat/c29:0
run/udev/tags/master-of-seat/+drm:card0-VGA-1
run/udev/tags/seat/c189:0
run/udev/tags/seat/c189:128
run/udev/tags/seat/c189:256
run/udev/tags/seat/c189:384
run/udev/tags/seat/c226:0
run/udev/tags/seat/c29:0
run/udev/tags/seat/+drm:card0-VGA-1
run/udev/tags/seat/+input:input0
run/udev/tags/seat/+input:input2
run/udev/tags/seat/+input:input3
run/udev/tags/seat/+input:input4
run/udev/tags/seat/+input:input5
run/utmp

anonym also mentioned filtering *.pyc files? It might be worth a few minutes figuring out what we could filter out every time, so as to reduce the diff's size on the long run?

Associated revisions

Revision 9ab7d456 (diff)
Added by intrigeri 5 months ago

Release process: automate clean up of the SquashFS sort file (refs: #16243)

History

#1 Updated by mercedes508 10 months ago

  • Status changed from New to Confirmed

#2 Updated by intrigeri 10 months ago

While preparing the 3.11 release, I've seen a bunch of updates under /run/udev. Latest file has:

Indeed, we could filter these out.

anonym also mentioned filtering *.pyc files? It might be worth a few minutes figuring out what we could filter out every time, so as to reduce the diff's size on the long run?

Yes, for some low value of "a few".

#3 Updated by intrigeri 5 months ago

  • Status changed from Confirmed to In Progress

#4 Updated by intrigeri 5 months ago

  • Assignee changed from anonym to CyrilBrulebois
  • Target version set to Tails_3.14
  • QA Check set to Ready for QA

Done straight on master, let's close this ticket if it works well during the 3.14 release process :)

#5 Updated by CyrilBrulebois 5 months ago

  • Target version changed from Tails_3.14 to Tails_3.15

#6 Updated by intrigeri 5 months ago

  • Status changed from In Progress to Needs Validation

#7 Updated by CyrilBrulebois 3 months ago

  • Target version changed from Tails_3.15 to Tails_3.16

#8 Updated by intrigeri about 2 months ago

  • Status changed from Needs Validation to Resolved

intrigeri wrote:

Done straight on master, let's close this ticket if it works well during the 3.14 release process :)

Since then, we published 4 releases and nobody expressed unhappiness here, so I'll assume we're good.

Also available in: Atom PDF