Project

General

Profile

Bug #16241

release_process: consider dropping the sid-only warning for IUK/upgrade-description

Added by CyrilBrulebois about 2 months ago. Updated about 2 months ago.

Status:
In Progress
Priority:
Normal
Category:
-
Target version:
-
Start date:
12/22/2018
Due date:
% Done:

0%

QA Check:
Ready for QA
Feature Branch:
Type of work:
Contributors documentation
Blueprint:
Starter:
Affected tool:

Description

Tools work just fine on stretch as evidenced by my releasing 3.10, 3.10.1, and 3.11, so let's remove this warning entirely?

Tentative patch attached.

0001-release_process-drop-IUK-upgrade-description-warning.patch View (1.1 KB) CyrilBrulebois, 12/22/2018 11:12 PM

Associated revisions

Revision 87a05a1b (diff)
Added by intrigeri about 2 months ago

Release process: clarify status of IUK tools on Debian stable and explain why (refs: #16241).

History

#1 Updated by mercedes508 about 2 months ago

  • Status changed from New to Confirmed

#2 Updated by intrigeri about 2 months ago

  • Status changed from Confirmed to In Progress

#3 Updated by intrigeri about 2 months ago

  • Assignee set to CyrilBrulebois
  • QA Check set to Ready for QA

Hi,

Tools work just fine on stretch as evidenced by my releasing 3.10, 3.10.1, and 3.11, so let's remove this warning entirely?

I'd rather not: there's historically been quite some bad feelings (mostly on anonym's side) about difficulties to run these tools in various environments. IIRC that's why this warning was added in the first place. The fact the tools currently work on Stretch don't guarantee they will still work on Stretch in 2 months, nor on Buster in a year. So I'd rather keep something in place.

But I agree the current phrasing is too vague, does not reflect currently reality, and does not explain well why things might break on stable. I've tried to improve this with 87a05a1b1fac4a673abdea939db4dc2416f69db0. What do you think?

Also available in: Atom PDF