Project

General

Profile

Feature #16234

Bug #15071: Make our server backup process more usable

add option for excludes to our backupscript

Added by groente 3 months ago. Updated 28 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Infrastructure
Target version:
Start date:
12/18/2018
Due date:
% Done:

100%

Spent time:
QA Check:
Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

the current backup script backs up the entire lv, we need a way to add exclude patterns.

History

#1 Updated by groente 3 months ago

  • Assignee changed from groente to intrigeri
  • QA Check set to Ready for QA
  • Feature Branch set to puppet-tails:feature/16234-excludes-for-backups

hey, can you see if this approach makes sense to you?

#2 Updated by intrigeri 2 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to groente
  • % Done changed from 0 to 60
  • QA Check deleted (Ready for QA)
  • This approach looks good to me. I'm curious to see the first example of real world usage, I think this will inform my assessement, so please deploy and start using it after taking care of what follows, then reassign to me for QA :)
  • no need to test for "$EXCFILE" existence since you're calling rm -f
  • I'm suspicious of /usr/bin/borg "${BORGOPTS}" create when $BORGOPTS is empty: it'll pass an additional (empty string) argument to borg, which might not like it. This might be a case when we need to remove quotes here, and ensure stuff is quoted in $BORGOPTS itself, e.g. BORGOPTS="--exclude-from '${EXCFILE}"'. I'm not 100% sure. Testing will tell.

#3 Updated by anonym about 2 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#4 Updated by groente 28 days ago

  • Status changed from In Progress to Resolved
  • % Done changed from 60 to 100
  • Feature Branch deleted (puppet-tails:feature/16234-excludes-for-backups)

done

Also available in: Atom PDF