Project

General

Profile

Feature #16222

Feature #15923: Autocrypt forces unencrypted messages

set Autocrypt settings via /etc/thunderbird/prefs/thunderbird.js

Added by hefee 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
12/13/2018
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
hefee/bugfix/16186-disable-autocrypt+force-all-tests
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Email Client

Description

patch /usr/share/xul-ext/enigmail/modules/preferences/defaultPrefs.js:
  • switch Autocrypt is off by default
  • mail.server.default.acPreferEncrypt is true, so if Autocrypt gets enables the "prefer-encrypt=mutual" is set by default.

See #16186#note-3


Related issues

Blocks Tails - Feature #15507: Core work 2019Q1: Foundations Team Resolved 04/08/2018

Associated revisions

Revision fb7863ec (diff)
Added by Sandro Knauß 4 months ago

disable Autocrypt by default for all new accounts (refs: #16222)

Revision 7f63bcd0 (diff)
Added by Sandro Knauß 4 months ago

disable Autocrypt by default for all new accounts (refs: #16222)

Revision 8b7a1cb6 (diff)
Added by Sandro Knauß 4 months ago

disable Autocrypt by default for all new accounts (refs: #16222)

Revision c293b923
Added by intrigeri 4 months ago

Merge branch 'hefee/bugfix/16186-disable-autocrypt+force-all-tests' into devel (Fix-committed: #15657, #15661, #16222)

Note: this branch actually does not do anything special wrt. Autocrypt,
nor does it address #16186 (if there's anything to address there, which
is unclear at the moment).

History

#1 Updated by intrigeri 5 months ago

  • Status changed from New to Confirmed
  • Assignee set to hefee

(Assuming this is part of your work on the parent ticket.)

#2 Updated by hefee 5 months ago

intrigeri wrote:

(Assuming this is part of your work on the parent ticket.)

Not necessarily, this part may be done by other team mates and with this to parts solved it is not clear if we can close the parent ticket. This is more like a better workaround to lead to better user experience. The parent task is mostly about communication with upsteam. That's at least how I handle the tasks.

#3 Updated by hefee 4 months ago

#4 Updated by intrigeri 4 months ago

hefee wrote:

patch /usr/share/xul-ext/enigmail/modules/preferences/defaultPrefs.js:
  • switch Autocrypt is off by default

I don't understand this part. Can you please clarify in the ticket description why 929c9cb6c88e1ca424dd80e1f7c998a06bebc538 is not sufficient?

Also, please retitle this ticket to clearly express what problem this will fix.

Finally, is the plan to do that for 3.12?

#5 Updated by hefee 4 months ago

  • Subject changed from change Autocrypt default settings to set Autocrypt settings via /etc/thunderbird/prefs/thunderbird.js

Hey,

patch /usr/share/xul-ext/enigmail/modules/preferences/defaultPrefs.js:
  • switch Autocrypt is off by default

I don't understand this part. Can you please clarify in the ticket description why 929c9cb6c88e1ca424dd80e1f7c998a06bebc538 is not sufficient?

the commit is touching the prefs.js for the user, but we wouldn't the script to fix it, if /etc/thunderbird/prefs/thunderbird.js ships it.

Also, please retitle this ticket to clearly express what problem this will fix.

Done

Finally, is the plan to do that for 3.12?

Yes, at least the part for /etc/thunderbird/prefs/thunderbird.js. The part that need to modify enigmail directly to enable acPreferEncrypt will properly be skipped, as we do not recommend Autocrypt anyways and I need to patch enigmail directly, what is to much work for this part.

#6 Updated by intrigeri 4 months ago

Finally, is the plan to do that for 3.12?

Yes, at least the part for /etc/thunderbird/prefs/thunderbird.js.

I think I understand now: the plan is to really disable Autocrypt, even for existing persistent profiles.

The part that need to modify enigmail directly to enable acPreferEncrypt will properly be skipped, as we do not recommend Autocrypt anyways and I need to patch enigmail directly, what is to much work for this part.

Absolutely, let's not bother about this one (at least for now): users who opt in for Autocrypt, i.e. non-default, unsupported configuration, can as well tweak this according to their taste.

#7 Updated by Anonymous 4 months ago

  • Status changed from Confirmed to In Progress

#8 Updated by hefee 4 months ago

  • Feature Branch set to hefee/bugfix/16186-disable-autocrypt+force-all-tests

#9 Updated by hefee 4 months ago

  • QA Check set to Ready for QA
Tests done on vm by hand:
  • register a new account
    + shutdown Thunderbird
  • made sure, that Autocrypt is disabled by default.

I bundled #15661, #16299, #15657 and #16222, as a new enigmail version and a new torbirdy version made sense to test together.

#10 Updated by intrigeri 4 months ago

  • Assignee changed from hefee to intrigeri

#11 Updated by intrigeri 4 months ago

  • Assignee changed from intrigeri to hefee
  • QA Check changed from Ready for QA to Dev Needed

Wrt. 9ec3ff6413691afd1794fd837fcac498f5164bf9:

  • Excellent! Very happy to see this cleaned up :)))
  • Are you sure you mean /usr/lib/xul-ext/torbirdy/defaults/preferences/prefs.js and not /usr/share/xul-ext/torbirdy/defaults/preferences/prefs.js? At least I don't have it on my sid system.

#12 Updated by hefee 4 months ago

  • QA Check changed from Dev Needed to Ready for QA

intrigeri wrote:

  • Are you sure you mean /usr/lib/xul-ext/torbirdy/defaults/preferences/prefs.js and not /usr/share/xul-ext/torbirdy/defaults/preferences/prefs.js? At least I don't have it on my sid system.

Too bad I haven't spotted that one.

#13 Updated by intrigeri 4 months ago

  • QA Check changed from Ready for QA to Dev Needed

Running thunderbird on the command line I see:

/usr/lib/thunderbird/defaults/syspref/thunderbird.js:73: prefs parse error: unknown keyword

Line 73 in that file is: prefs("mail.server.default.enableAutocrypt", false);. Seems that 7f63bcd06663fbcc013e2f45e46a6c4e11b7e9a8 is buggy. I'll stop testing here because I suspect this bug will make Thunderbird ignore other prefs, and then my testing could be invalidated.

#14 Updated by intrigeri 4 months ago

If you fix this + #15657 + #16222 today, I'll do another round of tests tonight with the commit for #16299 reverted. My goal would be to merge this branch with that revert tonight :) So please focus on these 3 issues first and go back to #16299 only after they're fixed (with the data I have in hand, it seems we don't have anything particular to do on #16299, at least not urgently).

#15 Updated by hefee 4 months ago

  • QA Check changed from Dev Needed to Ready for QA

intrigeri wrote:

Line 73 in that file is: prefs("mail.server.default.enableAutocrypt", false);. Seems that 7f63bcd06663fbcc013e2f45e46a6c4e11b7e9a8 is buggy. I'll stop testing here because I suspect this bug will make Thunderbird ignore other prefs, and then my testing could be invalidated.

fixed. So far I can tell, it does not stop Thunderbird to load the rest.

#16 Updated by hefee 4 months ago

  • Assignee changed from hefee to intrigeri

#17 Updated by intrigeri 4 months ago

  • % Done changed from 0 to 100
  • QA Check changed from Ready for QA to Pass

#18 Updated by intrigeri 4 months ago

  • Status changed from In Progress to Fix committed

#19 Updated by intrigeri 4 months ago

  • Assignee deleted (intrigeri)

#20 Updated by anonym 4 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF