Project

General

Profile

Bug #16205

Feature #15292: Distribute a USB image

Bug #16006: USB image: adjust documentation

Fix PO files on the USB image doc branch

Added by intrigeri 10 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
12/08/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

I realized today that I messed up when I prepared the USB image integration branch: I merged an old version of doc/16006-usb-images. So I've tried to fix that but then I realized that your branch (at least 0dac4d3822737d8f2657e41349d442f2efe8d081) makes tons of strings fuzzy in PO files, which will break lots of translations if we release it as-is. I think that's because the PO files were refreshed using a version of po4a newer than what's in Stretch. That version improves string extraction, which will be great once everyone who updates and consumes these PO files (our production website, translators, tech writers) all switch to that new version. Meanwhile, we have to stick to the po4a version that's in Stretch, otherwise .

So please fix this on your branch. It might be that reverting the aforementioned commit is enough, I dunno. Once you're done, please reassign to me so I take a last quick look and merge into our integration branch :)

I'll let you check things with Cody as needed so this does not happen again.


Related issues

Blocks Tails - Feature #16199: Publish a beta for USB images Resolved 12/07/2018

Associated revisions

Revision 25e0d3da
Added by intrigeri 10 months ago

Merge remote-tracking branch 'origin/doc/16006-usb-images' into feature/15292-usb-image (refs: #16205)

History

#1 Updated by intrigeri 10 months ago

#2 Updated by intrigeri 10 months ago

  • Blocks Bug #16198: Bootstrap an integration branch for the USB image project added

#3 Updated by sajolida 10 months ago

  • Assignee changed from sajolida to intrigeri
  • QA Check set to Ready for QA

What about 559877e299?

#4 Updated by intrigeri 10 months ago

  • Assignee changed from intrigeri to sajolida
  • QA Check changed from Ready for QA to Dev Needed

What about 559877e299?

Looks great, thanks!

Now, this branch introduces a lot of conflicts in wiki/src/**/*.po when trying to merge its base branch (devel) into it. Could you please merge current devel into this topic branch and resolve conflicts? Once that's done, I'll take one last look before merging into our integration branch and we can call the doc work done again! :)

#5 Updated by intrigeri 10 months ago

  • Target version changed from Tails_3.11 to Tails_3.12

#6 Updated by u 10 months ago

This is needed for releasing the beta, i.e. should be done really soon.

#7 Updated by sajolida 10 months ago

  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

Oops, I'm really sorry about that!

I did this work on December 18 before leaving for a few days (and as announce in my private email) but apparently I forgot to push it and update this ticket :(

See 0a82dcd94f, updated by 9e3df488a1.

#8 Updated by intrigeri 10 months ago

  • Status changed from Confirmed to In Progress

#9 Updated by intrigeri 10 months ago

  • Assignee changed from intrigeri to sajolida
  • Priority changed from Normal to High
  • % Done changed from 0 to 50
  • QA Check deleted (Ready for QA)

I've merged this into our feature/15292-usb-image integration branch and then I've diff'ed **/*.po between the devel branch and this one, and it appears that the problem this ticket was originally about is not entirely fixed: 559877e29937ffdd5166163b3b8a8485dab790f7 only partially reverted 0dac4d3822737d8f2657e41349d442f2efe8d081 and lots of website PO files still have strings erroneously marked fuzzy. For example, in wiki/src/about.de.po:

 #. type: Title =
-#, no-wrap
-msgid "Online anonymity and censorship circumvention\n" 
+#, fuzzy, no-wrap
+#| msgid "Online anonymity and censorship circumvention\n" 
+msgid "Online anonymity and censorship circumvention" 
 msgstr "Onlineanonymität und Zensurumgehung\n" 

I'm raising priority as this is one of the last blockers for releasing a beta.

Please base your work on the current integration branch. Thanks!

#10 Updated by intrigeri 10 months ago

  • Blocks deleted (Bug #16198: Bootstrap an integration branch for the USB image project)

#11 Updated by sajolida 10 months ago

  • Assignee changed from sajolida to intrigeri
  • QA Check set to Ready for QA

2 hours later I think I managed to fix my branch but I didn't manage to fix feature/15292-usb-image.

Here is what I did:

On my branch doc/16006-usb-images, I reverted 0dac4d3822 for real:

1. Roll back my branch doc/16006-usb-images to my last commit (b51606bae2).
2. Fully revert 0dac4d3822.
3. Merge origin/devel, checking out all PO files from origin/devel in conflicts.

→ Checking git diff origin/devel...doc/16006-usb-images, everything marked as "^+#, fuzzy" seems relevant (527 lines).

Then I tried to revert my previous buggy merges on your branch feature/15292-usb-image but failed.

Do you mind trying it yourself or guide me more?

#12 Updated by intrigeri 10 months ago

1. Roll back my branch doc/16006-usb-images to my last commit (b51606bae2).

A newer commit of yours on that branch was merged into our integration branch already so I don't understand how this can be a good starting point. Anyway:

→ Checking git diff origin/devel...doc/16006-usb-images, everything marked as "^+#, fuzzy" seems relevant (527 lines).

Great!

Then I tried to revert my previous buggy merges on your branch feature/15292-usb-image but failed.
Do you mind trying it yourself or guide me more?

Sure, I'll do what it takes to merge your current topic branch into our integration branch, i.e. apparently: manually fixing merge conflicts in a few dozens files.

#13 Updated by intrigeri 10 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100
  • QA Check deleted (Ready for QA)

#14 Updated by sajolida 10 months ago

I don't understand how this can be a good starting point.

I'm not sure if it's a rhetorical question or not. Anyway. After spending more than an hour trying to base my work feature/15292-usb-image as you requested, I was getting really weird results that I couldn't understand and decided to give up. That's probably because I was going Git operations that are beyond my current skills and don't really understand (yet). Rewriting the history of my branch allowed me to do something that I understood much better and seemed to work. That's why it was a good starting point for me.

#15 Updated by intrigeri 10 months ago

I don't understand how this can be a good starting point.

I'm not sure if it's a rhetorical question or not. Anyway. After spending more than an hour trying to base my work feature/15292-usb-image as you requested, I was getting really weird results that I couldn't understand and decided to give up. That's probably because I was going Git operations that are beyond my current skills and don't really understand (yet). Rewriting the history of my branch allowed me to do something that I understood much better and seemed to work. That's why it was a good starting point for me.

OK! Glad it worked for you :)

Also available in: Atom PDF