Project

General

Profile

Feature #16199

Feature #15292: Distribute a USB image

Publish a beta for USB images

Added by sajolida 10 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
12/07/2018
Due date:
% Done:

100%

Feature Branch:
doc/16199-usb-images-beta
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

  • Advertize it heavily to macOS (and Windows) users :)

linux.pdf (382 KB) sajolida, 01/07/2019 06:40 PM

macos.pdf (741 KB) sajolida, 01/07/2019 06:40 PM

windows.pdf (344 KB) sajolida, 01/07/2019 06:40 PM


Related issues

Blocked by Tails - Feature #16057: Test partitioning script in various scenarios Resolved 10/16/2018
Blocked by Tails - Bug #16198: Bootstrap an integration branch for the USB image project Resolved 12/07/2018
Blocked by Tails - Feature #16192: Upload and serve our copy of the Etcher binary Resolved 12/06/2018
Blocked by Tails - Bug #16068: Have a repo for the Etcher binary Resolved 10/21/2018
Blocked by Tails - Bug #16205: Fix PO files on the USB image doc branch Resolved 12/08/2018

Associated revisions

Revision 3c95aa07 (diff)
Added by intrigeri 9 months ago

Remove redundant word (refs: #16199)

Otherwise we have "also […] as well" which feels redundant.

Revision a13e4b70 (diff)
Added by intrigeri 9 months ago

Fix grammar (refs: #16199)

History

#1 Updated by u 10 months ago

  • Target version set to Tails_3.11

#2 Updated by intrigeri 10 months ago

  • Blocked by Bug #16002: Adjust our test suite for USB images added

#3 Updated by intrigeri 10 months ago

  • Blocked by Feature #16057: Test partitioning script in various scenarios added

#4 Updated by intrigeri 10 months ago

  • Blocked by Bug #16004: Make our automated test suite take into account USB image updates wrt. supported installation & update methods added

#5 Updated by intrigeri 10 months ago

  • Blocked by Bug #16003: Write automated tests for growing system partition added

#6 Updated by intrigeri 10 months ago

  • Blocked by Bug #16198: Bootstrap an integration branch for the USB image project added

#7 Updated by intrigeri 10 months ago

  • Blocked by Bug #15987: Check the system partition on every boot and grow it if needed added

#8 Updated by intrigeri 10 months ago

  • Blocked by Feature #16192: Upload and serve our copy of the Etcher binary added

#9 Updated by intrigeri 10 months ago

  • Blocked by Bug #16068: Have a repo for the Etcher binary added

#10 Updated by intrigeri 10 months ago

  • Target version changed from Tails_3.11 to Tails_3.12

I don't think all the blockers will be resolved in the next 3-4 days.

#11 Updated by intrigeri 10 months ago

  • Blocked by Bug #16205: Fix PO files on the USB image doc branch added

#12 Updated by sajolida 9 months ago

  • Blocked by Bug #15997: Test and release new Tails Verification added

#13 Updated by intrigeri 9 months ago

Blocked by Bug #15997: Test and release new Tails Verification added

I'm curious why.

#14 Updated by sajolida 9 months ago

  • Blocked by deleted (Bug #15997: Test and release new Tails Verification)

#15 Updated by sajolida 9 months ago

I'm curious why.

Indeed, it doesn't make sense as tester won't use the extension to
verify it.

#16 Updated by u 9 months ago

I've pinged the remaining subtask owners to finish their work on the blockers.

I think we might release the beta without the tests though.

#17 Updated by sajolida 9 months ago

  • Assignee changed from sajolida to intrigeri
  • QA Check set to Info Needed

I started writing the announcement in doc/16199-usb-images-beta.

It's not finished yet but I thought about asking your help to idenfity what we should tell people to test and report; if anything specific comes to your mind...

#18 Updated by sajolida 9 months ago

  • Feature Branch set to doc/16199-usb-images-beta

#20 Updated by intrigeri 9 months ago

We should at the very least do some manual testing ourselves before publishing a beta. I can check what the automated tests already correctly verify, merge the current integration branch into the automated tests branch, check the results, and then list on #16057 what needs to be manually tested.

#21 Updated by intrigeri 9 months ago

u wrote:

I think we might release the beta without the tests though.

Given kibi's other commitments (and mine, as the reviewer) my current best hope for merging the automated tests is January 10-11. I think we really need to release a beta earlier, so I propose we remove the blocking status of the automated test tickets here.

#22 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #15987: Check the system partition on every boot and grow it if needed)

#23 Updated by intrigeri 9 months ago

  • Assignee changed from intrigeri to sajolida
  • QA Check changed from Info Needed to Dev Needed

I thought about asking your help to idenfity what we should tell people to test and report; if anything specific comes to your mind...

Nothing particular to test. But it would be useful to explicitly request detailed info about OS and installation software (Etcher, GNOME Disks) versions for people who'll be reporting trouble, to ease triaging and reproducing.

#24 Updated by sajolida 9 months ago

  • File linux.pdf added
  • File macos.pdf added
  • File windows.pdf added

Here are the PDFs.

#25 Updated by sajolida 9 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

The call is ready on doc/16199-usb-images-beta.

Reassigning to intrigeri to:

#26 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #16004: Make our automated test suite take into account USB image updates wrt. supported installation & update methods)

#27 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #16003: Write automated tests for growing system partition)

#28 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #16002: Adjust our test suite for USB images)

#29 Updated by u 9 months ago

No more blockers for the release: let me know when you can do it (or just do it), please. Thanks! <3

#30 Updated by intrigeri 9 months ago

No more blockers for the release: let me know when you can do it (or just do it), please.

I'll work on this today and tomorrow, on top of the sprint I'm currently on, early mornings and late evening. If there are not too many bad surprises along the way, I'm confident the beta will be out by the end of the week.

#31 Updated by intrigeri 9 months ago

FTR the image I'm going to publish over rsync is tails-amd64-feature_15292-usb-image-3.12-20190104T1532Z-30967bfff6+devel@d93cb9e609.img.

#32 Updated by intrigeri 9 months ago

  • Assignee changed from intrigeri to sajolida

Reassigning to intrigeri to:

  • Review my work

Reviewed the blog post:

  • I've pushed a few fixes, please take a look.
  • I'm not sure about "an USB". Both seem to be acceptable but it seems that "a USB" is more common. Your call.

I'll now check the PDFs :)

Done on the topic branch, waiting for mirrors to pick it up.

#33 Updated by intrigeri 9 months ago

  • QA Check changed from Ready for QA to Dev Needed

I'll now check the PDFs :)

Looks good, only a few issues.

If one follows the Linux instructions, after completing the installation, if they have no other computer and no printer, they're told to visit https://tails.boum.org/install/linux/usb/#back → "Restart on the intermediary Tails" → "Install the final Tails". I suspect this will cause great confusion to some people since the blog posts advertises precisely "no need for an intermediary Tails" as one of the improvements we ask them to test. I think this problem can be fixed by removing the "Open these instructions on another device" section from the PDF, I hope that's cheap. I did not check if macOS and Windows are affected to the same degree.

The title of the macOS PDF is "Install from Mac using the command line", which does not sound quite right.

In passing, the HTTP links in the PDF are not rendered as links (one has to copy'n'paste the URL, which does not work very well e.g. when it's split over 2 lines). That's not a blocker for this beta but perhaps you want to track somewhere, so that's fixed next time you generate such PDFs :)

#34 Updated by intrigeri 9 months ago

  • % Done changed from 0 to 70

intrigeri wrote:

Done on the topic branch, waiting for mirrors to pick it up.

The mirrors should have it by now (at least the 2 ones in the round robin DNS pool have it). So feel free to merge into master (after updating the blog post's date) as you see fit.

#35 Updated by u 9 months ago

  • Assignee changed from sajolida to intrigeri
  • % Done changed from 70 to 0
  • QA Check changed from Dev Needed to Ready for QA

@sajolida, I am tempted to publish the blogpost myself now and let you fix the last remaining glitches in the PDF later.

#36 Updated by u 9 months ago

PDF glitches pointed out by intrigeri and one point I found at a glance:

macOS

- The title of the macOS PDF is "Install from Mac using the command line" should be "Install from Mac"
- The troubleshooting section mentions BIOS but not the MacOS boot menu. This should be made explicit.

- After completing the installation, if they have no other computer and no printer, they're told to visit https://tails.boum.org/install/linux/usb/#back → "Restart on the intermediary Tails" → "Install the final Tails". I suspect this will cause great confusion to some people since the blog posts advertises precisely "no need for an intermediary Tails" as one of the improvements we ask them to test. I think this problem can be fixed by removing the "Open these instructions on another device" section from the PDF, I hope that's cheap.

Linux

- The instructions lack the fact that one will be asked for a root/sudo password when installing using Gnome disks.
- After completing the installation, if they have no other computer and no printer, they're told to visit https://tails.boum.org/install/linux/usb/#back → "Restart on the intermediary Tails" → "Install the final Tails". I suspect this will cause great confusion to some people since the blog posts advertises precisely "no need for an intermediary Tails" as one of the improvements we ask them to test. I think this problem can be fixed by removing the "Open these instructions on another device" section from the PDF, I hope that's cheap.

Windows

- After completing the installation, if they have no other computer and no printer, they're told to visit https://tails.boum.org/install/linux/usb/#back → "Restart on the intermediary Tails" → "Install the final Tails". I suspect this will cause great confusion to some people since the blog posts advertises precisely "no need for an intermediary Tails" as one of the improvements we ask them to test. I think this problem can be fixed by removing the "Open these instructions on another device" section from the PDF, I hope that's cheap.

All

- HTTP links in the PDF are not rendered as link.

#37 Updated by u 9 months ago

I've also added a sentence to the blog post.

I see that the blog post will be announced on mailing lists, meaning that the links to the PDF might become obsolete, if we change them. Hence I cannot publish this yet :( Please let me know when you intend to do that.

#38 Updated by intrigeri 9 months ago

  • Assignee changed from intrigeri to sajolida
  • % Done changed from 0 to 70
  • QA Check changed from Ready for QA to Dev Needed

Assuming this was a mistake:

    Assignee changed from sajolida to intrigeri
    % Done changed from 70 to 0
    QA Check changed from Dev Needed to Ready for QA

#39 Updated by sajolida 9 months ago

  • I'm not sure about "an USB". Both seem to be acceptable but it seems
    that "a USB" is more common. Your call.

I'm not sure either... We've been using 'an USB' more but Wikipedia says
'a USB'.

I'll now check the PDFs :)

Thanks for the careful review! I didn't expect that but you found a
bunch of important stuff :)

If one follows the Linux instructions, after completing the installation, if they have no other computer and no printer, they're told to visit https://tails.boum.org/install/linux/usb/#back → "Restart on the intermediary Tails" → "Install the final Tails". I suspect this will cause great confusion to some people since the blog posts advertises precisely "no need for an intermediary Tails" as one of the improvements we ask them to test. I think this problem can be fixed by removing the "Open these instructions on another device" section from the PDF, I hope that's cheap. I did not check if macOS and Windows are affected to the same degree.

Indeed. I thought it wouldn't be a problem for the audience which will
be trying this out (likely more advanced users) but actually it's easy
to edit the page with the developers mode before print it to PDF so I'll
remove the section.

The title of the macOS PDF is "Install from Mac using the command line", which does not sound quite right.

Good catch! Fixed in e93d29eb69.

In passing, the HTTP links in the PDF are not rendered as links (one has to copy'n'paste the URL, which does not work very well e.g. when it's split over 2 lines). That's not a blocker for this beta but perhaps you want to track somewhere, so that's fixed next time you generate such PDFs :)

This comes from the PDF rendition of Firefox and I don't think we can
tweak that. That's what I meant when I said in the last meeting that
links wouldn't work. Hopefully we won't do this very often or for a
general public audience (it's the first time in 10 years, so...)

#40 Updated by sajolida 9 months ago

macOS

- The title of the macOS PDF is "Install from Mac using the command line" should be "Install from Mac"

Fixed in e93d29eb69.

- The troubleshooting section mentions BIOS but not the MacOS boot menu. This should be made explicit.

- After completing the installation, if they have no other computer and no printer, they're told to visit https://tails.boum.org/install/linux/usb/#back → "Restart on the intermediary Tails" → "Install the final Tails". I suspect this will cause great confusion to some people since the blog posts advertises precisely "no need for an intermediary Tails" as one of the improvements we ask them to test. I think this problem can be fixed by removing the "Open these instructions on another device" section from the PDF, I hope that's cheap.

I'll remove this option from the list.

Linux

- The instructions lack the fact that one will be asked for a root/sudo password when installing using Gnome disks.

I'll fix in the doc after publishing the beta. People testing the beta
will make it through.

- After completing the installation, if they have no other computer and no printer, they're told to visit https://tails.boum.org/install/linux/usb/#back → "Restart on the intermediary Tails" → "Install the final Tails". I suspect this will cause great confusion to some people since the blog posts advertises precisely "no need for an intermediary Tails" as one of the improvements we ask them to test. I think this problem can be fixed by removing the "Open these instructions on another device" section from the PDF, I hope that's cheap.

I'll remove this option from the list.

Windows

- After completing the installation, if they have no other computer and no printer, they're told to visit https://tails.boum.org/install/linux/usb/#back → "Restart on the intermediary Tails" → "Install the final Tails". I suspect this will cause great confusion to some people since the blog posts advertises precisely "no need for an intermediary Tails" as one of the improvements we ask them to test. I think this problem can be fixed by removing the "Open these instructions on another device" section from the PDF, I hope that's cheap.

I'll remove this option from the list.

#41 Updated by sajolida 9 months ago

  • File deleted (linux.pdf)

#42 Updated by sajolida 9 months ago

  • File deleted (macos.pdf)

#43 Updated by sajolida 9 months ago

  • File deleted (windows.pdf)

#44 Updated by sajolida 9 months ago

Updating the PDFs.

#45 Updated by sajolida 9 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Dev Needed)

#46 Updated by u 9 months ago

  • Assignee set to intrigeri
  • % Done changed from 70 to 0
  • QA Check set to Ready for QA

intrigeri wrote:

Assuming this was a mistake:

Ooops! Thank you lynx eyes!

#47 Updated by u 9 months ago

sajolida wrote:

Done: https://tails.boum.org/news/test_usb_images/.

YAAAAAAAAAAAY!

#48 Updated by intrigeri 9 months ago

  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100
  • QA Check changed from Ready for QA to Pass

u wrote:

intrigeri wrote:

Assuming this was a mistake:

Ooops! Thank you lynx eyes!

… and again :)

Also available in: Atom PDF