Project

General

Profile

Bug #16193

Upgrade Tor Browser to 8.0.4

Added by intrigeri about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
12/06/2018
Due date:
% Done:

100%

Feature Branch:
feature/16193-tor-browser-8.0.4
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser


Related issues

Blocks Tails - Feature #15506: Core work 2018Q4: Foundations Team Resolved 04/08/2018

Associated revisions

Revision aa1a936c (diff)
Added by anonym about 1 year ago

Upgrade Tor Browser to 8.0.4-build2.

Will-fix: #16193

Revision dc1a6d6d
Added by intrigeri about 1 year ago

Merge remote-tracking branch 'origin/feature/16193-tor-browser-8.0.4+force-all-tests' into stable (Fix-committed: #16193)

History

#1 Updated by intrigeri about 1 year ago

#2 Updated by intrigeri about 1 year ago

(Filing this mostly for FT accounting purposes and you'll need a ticket anyway to get reproducible build testing on Jenkins. I don't know how you've decided you would share this work so adding both as watchers.)

#3 Updated by anonym about 1 year ago

  • Assignee changed from CyrilBrulebois to anonym

#4 Updated by anonym about 1 year ago

  • Status changed from Confirmed to In Progress

#5 Updated by anonym about 1 year ago

  • % Done changed from 0 to 30
  • Feature Branch set to feature/16193-tor-browser-8.0.4

Imported! Next up, tests.

#6 Updated by intrigeri about 1 year ago

Feature Branch set to feature/16193-tor-browser-8.0.4

Imported! Next up, tests.

In passing, if our doc does not say so yet, it would be nice if it could tell to add the +force-all-tests suffix to the branch name, since most of the Tor Browser tests won't run on Jenkins otherwise. I've done this recently in wiki/src/contribute/Linux_kernel.mdwn, hoping it'll save us time :)

#7 Updated by CyrilBrulebois about 1 year ago

I did that yesterday but still waiting on the results.

  • test_Tails_ISO_feature-16193-tor-browser-8.0.4 is OK
  • test_Tails_ISO_feature-16193-tor-browser-8.0.4-force-all-tests isn't done yet.

#8 Updated by anonym about 1 year ago

  • Assignee changed from anonym to CyrilBrulebois
  • % Done changed from 30 to 50
  • QA Check set to Ready for QA

CyrilBrulebois wrote:

  • test_Tails_ISO_feature-16193-tor-browser-8.0.4-force-all-tests isn't done yet.

It now is: https://jenkins.tails.boum.org/job/test_Tails_ISO_feature-16193-tor-browser-8.0.4-force-all-tests/1/

None of the transient failures involves the Tor Browser in any way, so we're good!

Please review'n'merge!

#9 Updated by anonym about 1 year ago

On XMPP intrigeri offered to take this one over to lighten our RM's burden tomorrow, just so that's clear. I'll still assign it to the RM so it cannot be forgotten!

#10 Updated by intrigeri about 1 year ago

  • Assignee changed from CyrilBrulebois to intrigeri

#11 Updated by intrigeri about 1 year ago

Code review passes. I've verified that no -build3 is around and I assume you've checked with the Tor Browser folks that it's not planned. I confirm that the test suite failures happen on other +force-all-tests branches on Jenkins. Going to merge!

#12 Updated by intrigeri about 1 year ago

  • Status changed from In Progress to 11
  • % Done changed from 50 to 100

#13 Updated by intrigeri about 1 year ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

#14 Updated by CyrilBrulebois about 1 year ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF