Project

General

Profile

Bug #16172

Feature #15500: Update Puppet modules: 2018Q4 → 2019Q2 edition

Upgrade the puppet-concat module

Added by groente 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
11/29/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

Applying puppet-lizard-manifests on stone breaks with:

Error: Failed to apply catalog: uninitialized constant Puppet::Type::Concat_file

It does work with the latest concat version. Can you look into a suitable upgrade?


Related issues

Blocks Tails - Feature #16165: make puppet-lizard-manifests suitable for masterless puppet Resolved 11/28/2018
Blocks Tails - Feature #13284: Core work: Sysadmin (Adapt our infrastructure) Confirmed 06/30/2017

History

#1 Updated by groente 11 months ago

  • Blocks Feature #16165: make puppet-lizard-manifests suitable for masterless puppet added

#2 Updated by intrigeri 11 months ago

  • Blocks Feature #13284: Core work: Sysadmin (Adapt our infrastructure) added

#3 Updated by intrigeri 11 months ago

  • Subject changed from Upgrade puppet-concat to Upgrade the puppet-concat module
  • Target version set to Tails_3.11

#4 Updated by intrigeri 11 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to groente
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

Upgraded to 5.1.0, run Puppet agent on a few nodes, looks good! Please review and close if that fixed your problem :)

it did, thank you!

#5 Updated by groente 11 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (groente)
  • Target version deleted (Tails_3.11)
  • % Done changed from 50 to 100
  • QA Check deleted (Ready for QA)

#6 Updated by intrigeri 11 months ago

  • Target version set to Tails_3.11
  • QA Check set to Pass

Also available in: Atom PDF