Project

General

Profile

Bug #16146

Additional Software notifications failures

Added by bertagaz 8 months ago. Updated about 1 month ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
11/22/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

While intensively running the #14596 ASP test suite, I've noticed some failures in the notifications.

Run 80 in Jenkins shows:

sudo[8827]:     root : TTY=unknown ; PWD=/ ; USER=amnesia ; COMMAND=/usr/local/lib/tails-additional-software-notify \
  Installing your additional software from persistent storage... This can take several minutes.
sudo[8827]: pam_unix(sudo:session): session opened for user amnesia by (uid=0)
gnome-shell[5659]: Attempting to remove actor of type 'ShellTrayIcon' from group of class 'StButton', but the container\
  is not the actor's parent. 
gnome-session-binary[5463]: WARNING: Application 'org.gnome.Shell.desktop' killed by signal 6
sudo[8827]: pam_unix(sudo:session): session closed for user amnesia
tails-additional-software[7595]: [WARNING] Warning: unable to notify the user. Traceback (most recent call last):
tails-additional-software[7595]:   File "/usr/local/lib/tails-additional-software-notify", line 97, in <module>
tails-additional-software[7595]:     ASPNotifier(*sys.argv[1:])
tails-additional-software[7595]:   File "/usr/local/lib/tails-additional-software-notify", line 47, in __init__
tails-additional-software[7595]:     self.notification.show()
tails-additional-software[7595]: GLib.Error: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.NoReply: \
  Message recipient disconnected from message bus without replying (4)
tails-additional-software[7595]: [WARNING] The notification was: Installing your additional software from persistent \
  storage... This can take several minutes.
tails-additional-software[7595]: [INFO] Will install the following packages: cowsay

and later

tails-additional-software[7595]: [INFO] Installation completed successfully. 
sudo[917]:     root : TTY=unknown ; PWD=/ ; USER=amnesia ; ENV=DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus \
  ; COMMAND=/usr/bin/gdbus call --session --dest org.freedesktop.Notifications --object-path \
  /org/freedesktop/Notifications --method org.freedesktop.Notifications.CloseNotification None
sudo[917]: pam_unix(sudo:session): session opened for user amnesia by (uid=0) 

systemd[901]: Starting Add GTK bookmarks to some directories...
systemd[901]: Reached target Default. 
tails-additional-software[7595]: Error parsing parameter 1 of type 'u': unknown keyword:
tails-additional-software[7595]:   None
tails-additional-software[7595]:   ^
sudo[917]: pam_unix(sudo:session): session closed for user amnesia 
systemd[901]: Started Create the Tor Browser amnesiac and persistent directories. 
sudo[934]:     root : TTY=unknown ; PWD=/ ; USER=amnesia ; COMMAND=/usr/local/lib/tails-additional-software-notify \
 Additional software installed successfully

Run 84 exposes another type of failure:

tails-additional-software[8843]: [INFO] [INFO] Examining package changes
tails-additional-software[8843]: [INFO] Installation completed successfully.
sudo[1233]:     root : TTY=unknown ; PWD=/ ; USER=amnesia ; ENV=DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus \
  ; COMMAND=/usr/bin/gdbus call --session --dest org.freedesktop.Notifications --object-path \
  /org/freedesktop/Notifications --method org.freedesktop.Notifications.CloseNotification 1
sudo[1233]: pam_unix(sudo:session): session opened for user amnesia by (uid=0)
tails-additional-software[8843]: Error: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name \
  org.freedesktop.Notifications was not provided by any .service files
sudo[1233]: pam_unix(sudo:session): session closed for user amnesia
sudo[1253]:     root : TTY=unknown ; PWD=/ ; USER=amnesia ; COMMAND=/usr/local/lib/tails-additional-software-notify /
  Additional software installed successfully
sudo[1253]: pam_unix(sudo:session): session opened for user amnesia by (uid=0)
sudo[1253]: pam_unix(sudo:session): session closed for user amnesia
tails-additional-software[8843]: [WARNING] Warning: unable to notify the user. Traceback (most recent call last):
tails-additional-software[8843]:   File "/usr/local/lib/tails-additional-software-notify", line 97, in <module>
tails-additional-software[8843]:     ASPNotifier(*sys.argv[1:])
tails-additional-software[8843]:   File "/usr/local/lib/tails-additional-software-notify", line 47, in __init__
tails-additional-software[8843]:     self.notification.show()
tails-additional-software[8843]: GLib.Error: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: \
  The name org.freedesktop.Notifications was not provided by any .service files (2)
tails-additional-software[8843]: [WARNING] The notification was: Additional software installed successfully
systemd[1]: Started Install Additional Software Packages.

I've attach the logs and files of this runs for more debugging.

test_asp_80.journal (711 KB) bertagaz, 11/22/2018 03:47 PM

test_asp_80.debuglog (2.11 MB) bertagaz, 11/22/2018 03:48 PM

test_asp_80.png View (31.9 KB) bertagaz, 11/22/2018 03:48 PM

test_asp_84.journal (498 KB) bertagaz, 11/22/2018 03:48 PM

test_asp_84.debuglog (2.07 MB) bertagaz, 11/22/2018 03:49 PM

test_asp_84.png View (18.5 KB) bertagaz, 11/22/2018 03:50 PM

History

#1 Updated by alant 7 months ago

  • Assignee deleted (alant)
  • Affected tool deleted (Additional Software Packages)

Thanks for the catch. However, these issues seems me not to be caused by ASP.

1st failure seems me to be the consequence of gnome-session-binary[5463]: WARNING: Application 'org.gnome.Shell.desktop' killed by signal 6 which leade to GLib.Error: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying. This seems me to be an issue outside of ASP.

The 2nd failure is a consequence of the 1st.

The 3rd failure is caused by the lack of org.freedesktop.Notifications (tails-additional-software[8843]: Error: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files). I guess gnome-shell is not running anymore, but 3rd line shows that it was running as the notification to be closed got an id assigned (--method org.freedesktop.Notifications.CloseNotification 1). Before in the log I see Nov 22 07:21:35 amnesia kernel: gnome-session-f[9151]: segfault at 0 ip 000072b028a9a689 sp 00007ffc7cee2c40 error 4 in libgtk-3.so.0.2200.11[72b0287b7000+700000]. This also seems to be an issue outside of ASP.

#2 Updated by CyrilBrulebois 7 months ago

  • Target version changed from Tails_3.11 to Tails_3.12

#3 Updated by intrigeri 6 months ago

  • Assignee set to bertagaz
  • QA Check set to Info Needed

Dear Alan & bertagaz, please work together to decide what this ticket should become (rejected, new issues filed, whatever). Thanks!

#4 Updated by anonym 6 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#5 Updated by CyrilBrulebois 4 months ago

  • Target version changed from Tails_3.13 to Tails_3.14

#6 Updated by CyrilBrulebois about 2 months ago

  • Target version changed from Tails_3.14 to Tails_3.15

#7 Updated by intrigeri about 2 months ago

  • Status changed from Confirmed to Rejected
  • QA Check deleted (Info Needed)

All these failures seem to be caused by a well-known topIcons bug that crashes GNOME Shell. Please reopen if I guessed wrong and you can provide more info.

#8 Updated by anonym about 1 month ago

  • Target version changed from Tails_3.15 to Tails_3.14.1

Also available in: Atom PDF